Sanlink3 T1 not recognized when directly connected to laptop Dell 7720 [SOLVED]

  • Last Post 28 February 2018
iiee ann posted this 05 February 2018

I have used SanLink3 T1 with my laptop Dell Precision 7720 earlier and managed to get it work directly connected with laptop.

Few days ago i did a fresh installation of Win10.1709, and i did not know what i did wrong, SanLink3 won't be detected as TB3 device when connected to laptop, it shows something USB-C device, not working at all.  I have to use TB16 Thunderbolt3 Dock to connect to laptop, then connect SanLink3 to TB16 then only it will be detected and work properly.

Any advice or workabout for this? Thanks.

Order By: Standard | Latest | Votes
Pradeep Chidambaranath posted this 06 February 2018

Hi Iiee,

Kindly make sure to install the latest version of SANLink3T1 drivers to see how it works. Go to the link below to download the drivers.

If you still have any issues, please go to to create a support ticket and attach the system report for further investigation.

Could you please attach the complete system report for further investigation.

To generate a report, do the following:

1. Open System Information.

2. Select the information you want to export. For example, if you select System Summary, you'll be exporting every piece of information. However, if you only want to export your computer's graphic card details, you can simply select Display.

3. Click on File.

4. Click on Export.

5. Browse the location to save the file.

6. Enter a descriptive name and click Save to complete the task.

Pradeep C

iiee ann posted this 28 February 2018

Hi, this is update of the case.

The latest driver did not change the situation.  Anyway I manage to find the reason and solution.

The time when it was working directly connected to laptop was during the laptop bios 1.90, where intel rolled out 1st version of Meltdown & Spectre update.  That bios was then pulled back due to reboot issue, and I installed older bios version 1.84.  It was during this period that the NIC refused to work directly connected to laptop.  I have tried many ways including reinstall fresh Windows 10 but still it failed to work directly. 

Few days ago intel rolled out latest version of microcode update, and Dell responded with bios 1.91.  I installed this bios, and out of a sudden the Sanlink3 T1 has worked as normal, no need to go through Thunderbolt dock anymore.

This is really a very strange and rare case, but at least it is solved by now.

  • Liked by
  • Richard Oettinger