Apollo Cloud File Copy Disaster

  • Last Post 02 September 2020
John Clark posted this 15 April 2018


I bought the Apollo Cloud Duo and set it up about 10 days ago without a problem. 

Installing the Apollo Utility on my laptop stopped the VPN working, so I can no longer get email on my laptop. On other computers here, the VPN and email still work fine.

After transferring about 2tb of files to it via the Apollo Utility, I realised that there were errors in the transfer.

I decided to have another go and trashed the enclosing folder and emptied the trash. However the utility on my computer and phone and iPad all showed that the Apollo disc was 50% even though the trash was empty. That's the second fault.

I reset the Apollo. This worked OK but re-"claiming" the device was a problem. I had to restart the Apollo and the laptop several times before the serial number of the Apollo could be "claimed". 

I then transferred all my files (the original 2TB) to a USB 3 hard drive which took about 5 hours. Normally, copying takes longer than reading so I expected that the transfer onto the Apollo would not take any longer than this.

I started the USB transfer on Friday evening. I was disappointed to see that the Apollo had named the incoming data after the name of the USB hard drive, not after the enclosing folder on the hard drive. Anyway…

The transfer toiled away with its hard drive rattling away all over the weekend. I don't think I have seen such a slow transfer ever, even if it was USB 1. After 24 hours, only 5% was transferred!

Finally, on Monday morning, I checked the status of the transfer to find a message "transfer failed from USB device." with only 30% of the transfer completed.

I dragged the USB transfer folder to the trash. The folder disappeared from the files view but the Trash view says that the trash is empty. And 16 of the disc space on the Apollo is still taken up. So now I can't empty the trash and have only on optiojn… Reset the Apollo and start again. Misery!

I'm disappointed with the Apollo so far. While it is generally easy to connect, the limited interface is awful. For example, my 2TB is mainly photographs but I don't really want all 2TBs worth showing up in Photographs. There's no way to prevent this happening.

If I can even get my files onto the Apollo, I guess it will, in a limited way, do what I want but it could be so much more, with only a little more work from Promise.

I have looked in the manual for ways to get an error log. If search in the pdf manual for anything, the headings are all "returning the product…" Ominous. And nothing about logs.

Order By: Standard | Latest | Votes
Wendy Wei posted this 17 April 2018


We found that you also reported this issue to our support system.   Our tech support has sent you a reply.


John Clark posted this 17 April 2018

Hello Wendy,

I have not got any reply from Promise support on this subject. I've checked in the spam folder and cannot find any other messages than those regarding registering the device and registering on this forum.

Can you get support to copy the email here so I can be sure of reading it?

I'm still stuck with 16% used on the drive with no way of emptying the trash and using the drive other than another reset.

John Clark posted this 17 April 2018


I have checked the product registration page where "All communication with PROMISE Technical Support is stored here for future reference. The links to register new products or open a support case appear above on the navigation bar."

The Apollo is registered.

My email address appears to be correct.

There is a case ID - 20180415151054S which is a link. However the link goes nowhere… or nothing happens when the link is clicked.

Maybe there is something wrong with the support portal preventing your email getting to me?

Venkatachalam Settu posted this 18 April 2018

Hi John,

It may be a pop-up blocker issue. Refer the below link to disable the pop-up blocker.



Hamish J posted this 04 May 2018

It may be a pop-up blocker issue.

John Clark posted this 04 May 2018

Yes, thanks, it is a popup blocker problem. That fixed, I can read the Promise support email. Oddly, the Block pop-up windows checkbox appears in the Security prefs pane of my browser.

Unfortunately the suggestion to install something like Team Viewer is not one I am going to jump at for obvious reasons. See above.

>>First of all, Apollo won't work with VPN environment.  Please make sure your connection status on Apollo is LAN mode or P2P.  This could be found on setting page "status".  Also, no firewall connection to prevent Apollo from working.

That's not the point. The point is that when I install the Apollo app on my computer, it stops the VPN working. That's to say that it stops the VPN program launching. I could turn the VPN off if I wanted to use the Apollo box… however I don't have that option. So the choice is, get email at home or use the Apollo. Currently, email wins.

>>Secondly, the USB function has some bugs.  Please wait for next software release (possible in May) to fix USB file transfer issues.

Wow! You could have said that before I wasted a weekend waiting for a transfer not to work.

>>However, please check your USB file if it contents some characters such as NSString *regex = @"[.].*|.*[\\\\/:*?\"<>|]+.*", which might stop transferring and hang.

Well, since this product appears to be largely aimed at Mac users, you would imagine that you could use any file name which was used in OS X. Surely you can override the NSString function? We can let you know how…

With 50,000 files or so, how would you suggest checking for these characters?


>>Latter on, if you only want to transfer parts of USB files, you could go "Files" page and on the top select "+" -> "Transfer from USB"  This way will allow you only transfer the folder or files you want to upload to Apollo.  For large size of USB, we suggest to use this feature to transfer portion of files first.

I believe I tried that and it failed. Do I risk re-installing Apollo, stiffing the VPN and having another go? Isn't this what beta testing is for?









Aidan Montague posted this 13 July 2018

Same problem. After many hours of USB transfer, I get the message "Transfer failed from USB device". Not a reliable product.

Venkatachalam Settu posted this 06 October 2018

It would be pop-up blocker issue. Make sure to disable the pop-up blocker on your browser and new window will be opened to see the case details.

Aidan Montague posted this 06 October 2018

I am having another go at USB transfer with Apollo. PAINFULLY SLOW...but so far no error messages. Now on 16% and "Transfer in progress...". Will update with results. Fingers crossed.

John Clark posted this 08 October 2018

>>"Transfer in progress...". Fingers crossed.

You should not have to keep your fingers crossed if the drive worked properly!

It shoudn't be something where you have to contact technical support and they, somehow, do something remotely with the drive to get it to work. Does this have to be done every time?

Out of 8 USB transfer attempts, none have worked. One worked with Promise's intervention.

Not good enough.


Wendy Wei posted this 08 October 2018

Hi Aidan,

If you still have USB transfer issue, please go our support portal at: https://support.promise.com.  We can collect more information once you registered your Apollo (or you already registered) such as serial number and version.  By this way, we could find out the root cause.  We want to solve your USB transfer issue, but please understand the transfer would be related to individual network speed, and the case is not happened to everyone.



Wendy Wei posted this 08 October 2018

Hi John,

We understand and apology your painful experience of  USB transfer to Apollo earlier.  On our support website, I  explained to you earlier it was a bug thought not happened to everyone.  In order to solve immediately, we offered manual assitance to help you connect the USB and explain no data would be accessed.  The USB transfer was successful.  We also sent you a reminder the end of Sept., saying the latest firmware  was released and suggested you to try.  

During this period, you continue posting on Forum but we are not sure if you have updated to our last firmware and tried USB transfer yet.   Since you mentioned another noisy issue, we also offered to replace another unit for you but, again, without any reply from you on our eSupport.

The reason we don't suggest to use Forum to continue discussing your issue is becasue all your Apollo support information should be kept on the record.  We cannot provide you immediate service if you leave messages on different Forum topics with the same issue.  All your questions on Forum from now will be answered on our Support reply.  This would gaurantee you faster service too.

Kindly let us know on eSupport which way we could help.   



John Clark posted this 02 September 2020

Hello Preet1,

I have found a solution to my problems. After more than two years of failures with the Promise Apollo 2, I finally got there!

Cut your losses and buy an external hard drive case. Pull the drives out of the Apollo and install them in the external case. Bingo! Success! 

And put the remaining Apollo parts in the bin and get your life back.