WebPAM on 64-bit Fedora

  • Last Post 19 September 2017
  • Topic Is Solved
Liang-Wu Cai posted this 18 September 2017

I just updated my serever to Fedora 26, from a very old 32-bit system (Fedora 20?) in which WebPAM was used to monitor the SuperTrak 12350. Now the new OS is 64-bit, and the WebPAM installer failed to intall. Specifically, during the installation process it tried to intall Java's JRE and failed. I tried both versions of WebPAM that is avaialbe for download and get the same error.

Order By: Standard | Latest | Votes
Pradeep Chidambaranath posted this 18 September 2017

Hi Liang,

Please check the support ticket for update.


Pradeep C

R P posted this 18 September 2017

Hi Liang,

As I'm sure you are aware, this is a very old product and there is no telling when or if changes to the Linux enviornment will cause issues with WebPAM. Obviously it already has, but at least at this point, we can work around the Install issues. The root cause of your install failure is missing 32-bit libraries. You can install the missing libraries with the following commands.

sudo yum install glibc.i686

sudo yum install libXext.i686

After the libraries have been installed, you can install WebPAM (I used version 2.1) with the following command.

sudo sh WebPAM_2_2_0_66_lin.bin

Be advised that this will solve the install issue, but I don't know if WebPAM will work. I don't have a SuperTrak 12350 in my system, and WebPAM won't load. This may be because of the missing SuperTrak, but I cannot tell for sure.

One additional note, the firewall will probably block WebPAM, although turning it off did not work for me. To unblock the WebPAM port you can use the following command.

firewall-cmd --permanent --add-port=8443/tcp



Liang-Wu Cai posted this 19 September 2017

Thanks, Rich.

Following your instruction, it did install without any complaint. 

I also opened the ports of both 8080 and 8443; and also made sure that the service promisewebpam is running. But I still could not get to the WebPAM page, through either http or https.

Any further hints?

R P posted this 19 September 2017

Hi Liang,

One other aspect of this which I considered is the driver, but the stex driver is now inbox and has been since Fedora 9, it's part of the kernel build. But I did notice that in 2010 some bugs crept in and the stex driver did not work correctly. I could not tell if this was a problem with the driver itself or the kernel enviornment. But it was fixed at the time. So there is a possibility that the driver is not loading or loading but not working correctly and that this causes WebPAM to fail to run. As before I cannot check this.

Note, if the SuperTrak connected storage is working, then the driver is fine. If the LUN is offline then you can check the driver status with

dmesg | grep stex


sudo journalctl -b | grep stex

If the driver is not loading the standard path forward is to file a bug against Fedora.

If the driver is loading, then I'm not sure where to go from here.

I have no information about WebPAM itself, and do not know what to look for/at. If anything occurs to me I will check and update this thread.

One more thing, regarding workarounds. Perhaps you could install Fedora 6 as a dual boot system and install WebPAM on that. Then you could boot Fedora 6 to manage the storage. Not ideal, but it should work.