VTrak E630f throwing boot errors, drops to command line with no config menu

  • Last Post 16 May 2018
  • Topic Is Solved
Andrew Marx posted this 16 May 2018

Hi --

I'm trying to resurrect this controller we've had sitting around doing nothing for a year.  I'm able to get the serial connection to work, but upon boot, I get a lot of:

Buffer I/O error on device sda4, logical block xxxxxxx

with these afterwards:

WARNING - Previous boot of (0) INCOMPLETE
Error parsing config, syntax error, unexpected LL_IDENTIFIER, expecting $end in /islavista/config_user/sw/syslog-ng.conf at line 1, column 1:


syslog-ng documentation: http://www.balabit.com/support/documentation/?product=syslog-ng
mailing list: https://lists.balabit.hu/mailman/listinfo/syslog-ng
cp: read error: Input/output error
ERR: Copy config version file FAILED (1)
... FAILED (1)

It drops me to a command line afterwards.

I've tried to run the menu manually, but when I try to enter the username and password, it was the management service is not ready.  Is there anyway to flash the new firmware on top over serial from the command line?

Is there any way to reset this so it will start fresh?

Thanks for any pointers you can give.

Order By: Standard | Latest | Votes
Andrew Marx posted this 16 May 2018

It's definitely more than 3 years old -- probably closer to 5.  We inherited it from another unit.  Looks like it's destined for the scrap heap.  C'est la vie!

Richard Oettinger posted this 16 May 2018

Indeed - they are unusable.

If the x30 is out of warranty, the repair will be expensive... 8^)

Andrew Marx posted this 16 May 2018

So getting those same errors on both controllers means it's pretty darn fubar'd, I guess...  Thanks for the info -- I'll open up a support ticket to see if there's any chance of getting these fixed.

Richard Oettinger posted this 16 May 2018

The serial connection is the console for that physical controller, so if it outputs errors they are for that controller - not the other.

Andrew Marx posted this 16 May 2018

Does it matter which controller I'm connecting to?  I get the same results plugging the serial connection into either controller.

Richard Oettinger posted this 16 May 2018

sda4 is the controllers flash module.

It appears to have failed, so the controller needs to be replaced...

Andrew Marx posted this 16 May 2018

if I try to cat a few files in /islavista/config/sw, I get more I/O errors.  Is the flash memory corrupted?