SuperTrak EX8650 (defective): Accessing array with different controller?

  • Last Post 21 January 2018
Sebastian Fischer posted this 21 November 2017


I've had a SuperTrak EX8650 in use for quite a while now, running a Raid 6 array of 5 disks (4 TB each) with 1 assigned hot-spare (but no BBU). It uses the latest available firmware (from 2011 or 2012: V1.10.0000.01).

First, some background and a description of what's happened: A few days ago the controller suddenly stopped working: it started beeping (two short consecutive beeps, repeating). After that the system froze on the first access to the array. This happened a few more time, but I was able to back up some of the data (about half) as it worked for abouit a day and a half. Unfortunately, I can no longer get the system to boot without it starting to beep for more than a minute (if at all, usually beeping starts during the controller post screen now).

Now it looks like the controller itself is dying: When I disconnect the drives and enter the controllers own BIOS, I can't access the Log, it just tries for a good while and eventually reports error 0x80. I've entered the bios once with drives connected (enduring the incessant beeping), and I wasn't able to do anything useful either. I did get a message similar to "Internal error in firmware raid core" or something similar.

If the exact message matters, I can try that again.

My actual question:

  • I assume I can access the array normally if I get a hold of a replacement controller of the same type?
    • The problem is, these are relatively hard to get here (germany/europe)
    • and/or expensive for just reading the data basically once...
  • But can I also access the array with a similar controller but of slightly different type?
    • For example, would a EX8350 work? It's much more easily available.
    • Of course I'd need some different cables? But other than that?
    • I don't see a firmware of similar age as mine (those for EX8350 are older), and that concerns me as one of the (only) changes was supporting drives over 2TB (and sectors above 4k).
  • Are there any other (simple/cheap) options?


Thank you


Order By: Standard | Latest | Votes
Richard Oettinger posted this 21 November 2017

Hi Sebatian,

You've said "I've had a SuperTrak EX8350", but then ask "would a EX8350 work?". They are the same. 8^)

By design, any Promise SuperTrak should be able to read your disk array.

Sebastian Fischer posted this 21 November 2017

Hello Richard,

thanks for pointing it out, with that typo the question really makes very little sense. Sorry!

To be clear: I have an EX8650, which is hard to get anywhere nowadays (let alone reasonably cheap). There are some EX8350 though (and many EX4350, which probably won't be of any help).

My concern is that the EX8650 only got >2TB support in one of the last firmware updates (2011 or 2012 I think).

As far as I can tell, the EX8350 can't handle my ~10.5 TB logical raid 6 array (over 5 disks @4TB each), as it's possibly limited to 6.5 TB total size (source: serverfault post). Now, does it mean when I connect the array it simply won't work? Or will I be able to access the first ~6.5TB (which would probably be good enough for me)?

Generally, if I do get an EX8350, is there a way to 'safely' connect the array (basically force a read-only mode)?

What other options do I have left for reading the data? would newer controllers work, and is there a limit to how new they could be (did the raid meta format on disk change at any point)? Are there some by other vendors that are compatible (f.ex. using the same or a similar controller chip)?


Thank you again


R P posted this 22 November 2017

Hi Sebastian,

The Ex8650 and the Ex8350 are not in the same product family as I had thought, I was comparing the Ex4650 and the Ex8650, which are in the same product family.

The Ex4350 and the Ex8650 use the same firmware file, so they should be interchangeable, the Ex8350 uses a different firmware file and there may be differences in what they support. I do not have any documentation so I cannot verify anything. I'd say that you should go for the Ex4350.

Since you have a 4-drive RAID6, you can plug in everything but the spare drive and you should be able to access your data.



Sebastian Fischer posted this 22 November 2017

Hi Richard,

If I read this right you have a 4-drive RAID6 + 1 hot spare.

sorry, no: it's a 5-drive-array with an additional hot spare (total of 6). I assumed the array wouldn't care (much) if the hot spare was there or not... So the EX4350 is probably out, unless it would let me read the contents with 4 of the 5 drives (technically even 3 should be enough, right?).

Unless I'm mistaken they use the same firmware.

They do not. The latest for EX8350 is (02/2009), while the newest for the EX8650 is V1.10.0000.01 (06/2012), with release notest stating that V1.10.0000.00 (from 2011) added support for drives >2TB and sector sizes >4k (I honestly don't know what size I've used). That's the main source of my doubt if this can work, with the serverfault post I linked in my last post being the next concern.

 This is a quote from the manual of the EX8350:

Q: What it the maximum physical drive storage capacity of SuperTrak EX 


A: The SuperTrak EX8300 and EX8350 support up to 6.0 TB (eight 750 GB 

physical drives).

But it also says this:

Q: What kind of HDDs can I use for a SuperTrak EX Series logical drive? 

A: You can use any Serial ATA hard drive(s) to create arrays on the SuperTrak 

EX Series. Use matching drives for multiple-drive arrays to maximize 

capacity usage as well as performance.

Basically it's hard to just guess how it'll behave and I might need someone from Promise who knows (or can check) what options are plausible for me.

I'd frankly just give it a try with a 8350 (I'm reasonably sure I could get one soon-ish), if I knew if there were any risks in just connecting the drives up and entering the controllers BIOS to see what it does with them... That would be really important to know though!


Thank you all once more


R P posted this 22 November 2017

Hi Sebastian,

Sorry, I noticed that and updated my post, but not before you saw it, you are correct.

>sorry, no: it's a 5-drive-array with an additional hot spare (total of 6). I assumed the array wouldn't care (much) if the hot spare was there or not... So the EX4350 is probably out, unless it would let me read the contents with 4 of the 5 drives (technically even 3 should be enough, right?).

OK, then there is still hope with the Ex4350. A RAID6 can tolerate 2 missing drives, if you get the Ex4350, update to the latest firmware and plugin 4 drives from the array, you should be able to accept the incomplete array in the CLI. This should give you a degraded RAID6 array, but you should still have access to your data. And you are correct, you would need 3-drives minimum.

The CLI command would look like this...

> array -a accept -d 0

So I guess the Ex8650 would still be best if you can find one, but the Ex4350 should work if you can't find an Ex8650.

R P posted this 22 November 2017

Hi Sebastian,

I am having a bad day and getting numbers confused. These are the cards in question.

Ex8650 (what you have)

Ex8350 (choice 1)

Ex4350 (choice 2)

The Ex8350 and Ex4350 are in the same product family and neither uses the same firmware as the Ex8650.

If you could find an Ex4650 you would have the 4-drive version of the Ex8650, this would be a better alternative.

If you want to see what has been tested check the compatibility lists, the Ex8350's compaibility list shows that no 1TB drives have been tested, the Ex8650 has a 2011 compatibility list and it shows drives up to 3TB have been tested.

So how either the Ex8350 or the Ex4350 will handle 4TB drives is unknown, they may work OK, or bad things may happen.

I would suggest that if you go with either, that you don't try to write to the LUN, do only reads to offload your data.


Sebastian Fischer posted this 22 November 2017

 Hi Richard,

yea I agree that it doesn't look like I can expect any of the EXx350 to work for me.

Considering their age and the fact that drive support for over 2TB was explicitly mentioned in the release notes for the x650, but not the x350 makes me doubt it'll work. This sounds suspiciously like a 32/64 bit issue, and I'm not gonna risk it.

Again, thank you for your advice and help. I'll just have an EX8650 shipped here, which apparently might take until january if I'm unlucky (let's hope not though). The EX4650 that are available also seem to be mostlny in the US. There appears to be little price difference anyway, so Imight as well go for the 'read thing', even if it might take a little while longer...


Thank you once more

fritz treitinger posted this 21 January 2018

hello sebastian, how worked things out for you? i am facing similar situation since today :(