Promise Utility not working on Pegasus R6 (MacOS Sierra)

  • Last Post 13 October 2020
Santiago Montero posted this 24 November 2016


I have a Pegasus R6. Since I updated my iMac (mid 2011) to MacOS Sierra (v. 10.12.1) the stopped working. This means that no graphical interface shows up when opening the I still can open some menus thought (see the attached screenshot). The R6 is not detected as external disk either. I downloaded and installed the last version of the utility ( but still it did not have any effect on this issue. I haven't tried to solve it through command line but I will be willing to (if needed). Any help? Thanks!

Attached Files

Order By: Standard | Latest | Votes
Tomas Egger posted this 13 October 2020

Ola my friends,

I tried these simple steps and Its working now:

- Please move the promise utility to trash, and empty the trash. 

- Then download the latest promise utility software

- Once after installing the promise utility, Restart the unit and the mac, first turn off mac and then turn off the pegasus wait for 2 minutes and then turn on the mac and wait until it is fully booted then turn on the pegasus and wait for 2 to 3 minutes and then try to launch the utility, see if it works.

- Working fine for me now.



Ranjith kumar posted this 20 January 2020

Hi Ttiz,

Yes, it will work, but before that kindly let us know
issue which are facing?
Also let us know the Mac OS version and utility version if you have Promise utility
access issue?


Promise Team

Venkatachalam Settu posted this 24 November 2016


Please open a case at or call us at (408) 228-1500 to troubleshoot the issue.


Santiago Montero posted this 24 November 2016

Hi Venkatachalam,

Thanks for your fast answer. I pull out half way from the unit all the six drives. I turned ON the unit without the drives and launched Still the same issue (no graphical interface shows up and R6 is not detected as external disk either).

Thanks again for your help!

Venkatachalam Settu posted this 24 November 2016

Hi Santiago,

Could you please follow the steps and let me know the status?

- Shutdown the pegasus using the power button
- If it's not working unplug the power cable.
- Mark and Remove all the drives from the unit (half way from the unit)
- Turn ON the unit without the drives
- Open Promise Utility.


Santiago Montero posted this 24 November 2016

Thanks for your answer, Devendra!

I followed all steps above. As you suggested, I changed the port number away from 8080 in the 'httpd.conf' file within Promise Utility's Package Contents. Then I launched again. Unfortunately, I still have exactly the same issue. I tried all the port numbers that you mentioned. Moreover, I used the 'lsof' command to check if there is any service running. If I do not launch, the 'lsof' command does not produce any message for any of those port numbers (8080, 8088, 8079, 9090). However, if I previously launch and use the 'lsof' command on the same port number that I specified in the ''httpd.conf' file, then I do get an output. What can I do more? Thanks for your help!

Devendra Kumar posted this 24 November 2016

Hi Santiago,

Could you please trash the current Promise utility and Re-install the utility and check if it works. If still, the issue remains same please follow the below step.

Apache webserver locally hosted is set to use port 8080 and Promise Utility uses the same port which causes conflict with the process its set to run and fails to launch

Workaround: Change the port number from 8080 to 8088 or 8089 etc. This will make the Promise Utility use a different Port number rather than the one used by Apache

1. Go into Applications then Utilities.
2. Locate Promise Utility.
3. Right, click and select Show Package Contents.
4. Within Promise Utility package, browse to Contents/Resources/apache2/conf/.
5. Open file 'httpd.conf' with TextEdit.
6. Search the file 'httpd.conf' for '8080'
7. Change the port number of the Listen command away from 8080 to another port number.  Try 8088, 8079 or 9090, etc..., these should all be free
8. Save the file in TextEdit.
9. Launch Promise Utility from Applications.

Note: You can use the below command to check for free ports to substitute in place of 8080

Syntax: lsof -n -i:$PORT | grep LISTEN

Example: lsof -n -i:8088 | grep LISTEN

The above command returns back to the default CLI prompt without returning any message if there is no service running on port 8088.