Promise Pegasus R4 firmware/utility losing communication with Finder in OS X Yosemite 10.10.5

  • Last Post 16 March 2019
John O posted this 01 April 2016

Hi Guys, 

I'm having major issues with my Promise Pegasus R4 running on Yosemite 10.10.5 and Promise Utility Firmware Version 3.18.0000.36.  

When I first boot up the OS X sees the R4 just fine, I can get in and look at clips via Finder, tag, rename, etc.  After minutes, maybe 15 mins, it's no longer happy.  Finder begins to freeze, spin, hang forever, and where I usually can (as I do on any other drive, and previously on my R4) view clips, do a two-finger touchpad scrub through them in a Finder window, here it will freeze before I can even see the clip's video image, it will not show the video and immediately produces the 'ole beach ball.  This ONLY happens on my Pegasus, no other drives.

I originally treated this as an OSX 10.10.5 issue.  I trashed Finder and Sidebar (as I thought initially it could have something to do with high volume of tags) plists, but none of this seems to have anything to do with it.  

The R4 is cleanly formatted RAID 5 (12TB usable, with only 4TB of media on it). 

Please, Promise, Wise Users, anyone, this is an SOS. Any help would be sooo appreciated.  I really need my Promise Pegasus R4 to play well with others so that I can finish my job.  As it is I cannot access my work.


J. Oak

Order By: Standard | Latest | Votes
Joe Engledow posted this 01 April 2016

This does not sound like any known issue we've come across. We'd like to help you on an individual case basis.

Please call technical support at 408-228-1500 during Pegasus support hours (9am-5pm PST, Mon-Fri. After hours support is available for an additional fee.) We require registration at so we can start a service history; if you don't have an account there, we'll help you make one.

John O posted this 01 April 2016

I'm a registered user.  I talked to someone a few days ago, provided subsystem info, event log, etc.  We updated the firmware but the problem persists.

Joe Engledow posted this 01 April 2016

Sorry to hear it.

Please update that existing case using the Reply button, fill out the current problem (that it is still persisting) and then click Submit, or call the support line if you've already done that.

John O posted this 05 April 2016

So I've tried the latest firmware update for my Promise Pegasus R4, I tried the RAID with OS 10.10.4, OS 10.10.5, and on another system running OS 10.7.5, and all produce the same result: Mac OS's Finder starts to pause, freeze, hang for up to 10 mins.  

Is something being done to address this Promise firmware/software update for the Pegasus R4?  Please address it, as my work depends on it, as I'm sure others who make the update.    

Thanks in advance.

Joe Engledow posted this 05 April 2016

There is no known issue. This needs to be handled within eSupport. Please call 408-228-1500 and escalate your case.

John O posted this 06 April 2016

I don't see it in this thread but I was sent via the team a link with instructions via the Admin panel in the Promise Utilty to update to firmware 50.40000.56, and I dutifully followed these, yet the problem persists: serious hang time.  As a test I tried to create a smart folder on the volume and it went into hang mode until Finder produced an "error -50" code.

Jerry Case posted this 06 April 2016

Hello John,

Please contact support directly for this issue.  There are no known issues with any lockup like this.  Since you are having locking up problem, it could be other factors that need a more indepth look. It could be drive related, chassis related, cable related, or some other unknown issue that we need to troubleshoot to find the root cause.

Please open a support case at or phone 408-228-1500 and follow the promots to Pegasus support.



Piotr Jagninski posted this 30 October 2017

I am having a very similar problem with my Pegasus 2 R4 (the "diskless" unit, into which I installed three 2TB Hitachi drives (HUA722020ALA330) in Raid 5 and one 2TB Western Digital (WD2001FASS-0) as a Time Machine backup drive. Running MacPro (garbage can) with OSX Sierra 10.12.6, Pegasus Firmware 5.04.0000.61 .

Worked great for at least a year after I bought it (new). Then I updated the firmware on the Pegasus unit and bingo problems with freezing of the Finder, blank desktop, beachball, slow system, etc.

As soon as I disconnect the thunderbolt connector from the Pegasus unit, the "blank" finder returns, though system slowdown can sometimes persist. With the drive connected this happens multiple times a day.

With thunderbolt connector disconnected from my Mac, the Pegasus unit can no longer be turned off using the power switch... sometimes two sometimes four drive activity LED lights will be blinking in unison. The only way to regain control of the unit is to physically disconnect the power plug.

For the Pegasus unit to become operational with my Mac once more, I often am forced to reboot the Mac AND turn off the Pegasus unit. Restarting both clears the problem completely... until it resurfaces again a while later, forcing me to start the process all over again. If I don't use the Pegasus unit, no problems with my Mac at all.


-- Piotr Jagninski

  • Liked by
  • Erin McCuskey
  • Michael Lupo
Erin McCuskey posted this 07 November 2017

I am having the same issues. Mac Pro (macOS Sierra 10.12.6) started acting up only when the 6Tb Pegasus2R4 was connected. Updated finder and cleaned up Mac Pro as suggested. Now I can see the drive but not the individual files on it. Freaking out in Australia

Venkatachalam Settu posted this 07 November 2017

Hi Erin,

Could you please send us the latest subsystem report.

Steps to save the subsystem report :

- Open Promise Utility
- Click subsystem information icon on the top of the window
- Click the lock symbol on the left bottom corner of the screen to unlock the utility
- Click on save service report button to save the subsystem report.


Thank you.

Alex Besch posted this 16 March 2019

is there a solution for this problem available?