Promise Pegasus 3 not seen on Mac

  • 169 Views
  • Last Post 03 July 2018
Pieter Pretorius posted this 24 February 2018

I have a new Pegasus 3 24TB drive, and a new Macbook Pro. Sometimes depsite being on, the Pegasus is not seen on Finder. When that happens, I also cannot swith the Pegasus off by depressing the button on the Pegasus. The only way to get the Mac to see the Pegasus, is to unplug the Pegasus' power cord, and then plug it back to restart. I run High Sierra on the Mac.

 

Normally, if I press the button on the Pegasus, it goes red and then switches off.

Order By: Standard | Latest | Votes
Pradeep Chidambaranath posted this 24 February 2018

Hi Pieter,

Does it have any specific pattern? Does it happen when you try to copy large files? Have you tried connecting this unit to a different computer to see if the issue follow? Have you tried with a known working thunderbolt cable?

Go to the link below to download the later drives.

https://promise.com/DownloadFile.aspx?DownloadFileUID=4535

Kindly install the latest version of drives to see how it works. If you still have the same issue, please go to https://support.promise.com to register the product and create a support ticket with the latest subsystem report and the MAC profiler for further investigation.

Go to the below link to download the latest version of the utility.

https://promise.com/DownloadFile.aspx?DownloadFileUID=4617

Follow the below step to save the subsystem report for further investigation.

- Open Promise Utility.
- Click subsystem information icon on the top of the window.
- Click the lock symbol in the left bottom corner of the screen to unlock the utility.
- Click on save service report button to save the subsystem report.

Regards
Pradeep C

Pieter Pretorius posted this 15 June 2018

This still happens to me all the time. There is no pattern. I've got a Prmoise Pegaus 3 as well as an older Promise Pegaus. The older on is daisy-chained to the 3. My Macbook will continue to see the older one, but the 3 just drops out, and even a restart of the Mac won't fix it. The onlu solution as said above, is to unplug the power cable and replug it.

 

Frustrating!!!! 

Pieter Pretorius posted this 15 June 2018

EVERY TIME I try to install the above latest drivers in the link above, my Macbook crahses halfway though installation. EVERY TIME!!!!

Pieter Pretorius posted this 16 June 2018

I installed the new firmware via the app menu system, but the driver installation still crashes my Mac every time I try and run that. I downloaded the lastest of them all from the downlaod website.

Pieter Pretorius posted this 03 July 2018

Don't you ever answer anything here Promise?

Venkatachalam Settu posted this 03 July 2018

Please open a case at http://support.promise.com or call at (408) 228-1500 to troubleshoot the issue.

Pieter Pretorius posted this 03 July 2018

There isn't currently a driver for Mac available, I see

 

Close