Pegasus1 R6 Firware update stuck at 99% then Promise Utility crashed

  • 939 Views
  • Last Post 23 August 2017
David Vandenborn posted this 23 August 2017

We've got several Pegasus R6 units. Today I updated the Promise Utility to version 4.00.0000.08. Once that version was installed I received new firmware updates (5.04.0000.61) for the Pegasus units. The units are now running 5.04.0000.57.

On a Mac Mini mid 2011 running 10.10.5 we've two R6 units connected.

I started by updating only one R6 unit to the latest firmware version on that Mac Mini. What happened is that the firmware update gets stuck at 99% - Updating Image. It stayed there for more than an hour. While the firmware update was stuck at 99% I navigated in the Promise Utility to Check for Updates. Next thing that happened, Promise Utility crashed & quited. 

I've now restarted the Promise Utility and have restarted the Firmware update. Again it's stuck at 99%.

In the Console the following log entry gets repeated every 10 seconds:

23/08/17 11:06:04,448 com.apple.xpc.launchd[1]: (com.promise.BGPMain_R[4638]) Service exited due to signal: User defined signal 1: 30

I'm afraid that the R6 will be bricked when I turn off or power cycle it. What's the best action to take at this moment without bricking the R6?

David

David Vandenborn posted this 23 August 2017

I've been able to resolve the issue.

When I rebooted the Mac Mini I tried to perform the firmware upgrade again. But it kept getting stuck at 99%. I force quited the application and tried applying the upgrade using promiseutil. When I tried it I got the following error message:

cliib> ptiflash -f /Users/nameofuser/Desktop/R_SI_504000061.img

Error (0x49815102): subsystem lock by other is present

 

In the end I configured a MacBook Pro running 10.10.5, downloaded the Promise Utility and installed it. This time it said version 4.00.0000.09. I then connected the R6 to the MacBook Pro and applied the firmware update using the Promise Utility. The update process lasted a few seconds and was succesfull. I then unmounted the volume and power cycled the R6. The unit is now on 5.04.0000.61.

 

David 

Close