Pegasus R6 won't connect after firmware update

  • 610 Views
  • Last Post 06 November 2017
Ryan Roehl posted this 18 October 2017

Was having issues getting pegasus R6 to initlally connect. (no issues once connected). Tried updating firmware. After Update finished and it instructed to restart the unit, I tried by holding the power button for 30 seconds. Didn't work. Tried for up to 2 minutes. Ended up unplugging power to reboot.

On Reboot power led goes from orange than to red. All 6 drives have the top LED lit, but only the bottom have drives have the bottom led lit. Every once in a while they flicker.

System Information on Mac OS sees it on the thunderbolt port, but the promise utility does not.

Help?

Order By: Standard | Latest | Votes
Hariprasad Velmurugan posted this 18 October 2017

Hi Ryan,

It seems that after upgrading firmware pegasus unit stopped working

Need to trubleshoot further to find out the issue,For further technical assistance please contact  promise support (408-228-1500)

Regards

Hari

Ryan Roehl posted this 19 October 2017

I did and they wanted over $100 to talk to me, so I thought I'd try here.

Ryan Roehl posted this 30 October 2017

So is this for real? There's a public forum for support, but all you get out of it is call promise for support, making the public forum useless?

Yu Qin posted this 06 November 2017

Hi Ryan,

Try removing all drives when the machine is off, then turn it on and Utility should open. Paste the service report here.

Close