Pegasus R6 (Series 1) makes explorer.exe hang around 12% CPU usage when plugged in.

  • Last Post 14 March 2018
Karim El Dib posted this 14 March 2018



I have been using two Pegasus R6 Series 1 units for some years on a  Windows 7 x64 based computer with no problems until now. 

When I start the computer with the devices powered on, they make explorer.exe process almost hang with a constant 12-13% CPU usage, rendering Windows unusuable, applications hanging, Recycle Bin impossible to open, and I can't access my files on the Pegasus drives.

They used to work perfectly fine for years and I have not changed anything to the configuration of the machine, applications, drivers or OS, but the problem suddenly showed up out of the blue three weeks ago, without any major update before it whatsoever. 

When I start the computer without the Pegasus drive attached, it runs perfectly fine without any od the problems described. 

Both Pegasus units are running perfectly fine on Mac OS X, and are in perfect conditions according to the Pegasus Utility. All LED indicators are blue. Both Unit never moved from the shelf they are stored on neither ever had any physical incident.

I did have to replace a failing hard drive in one of the unit once, followed the Promise procedure and replaced it with success, further running and using the unit without any problem for a whole year till this one arose.

Each unit is connected on a separate thunderbolt port on a Gigabyte Z77x-UP5-TH motherboard running its latest Bios version (F12)

The PC is running Windows 7 64 Ultimate with all the latest important and recommanded Windows Updates and latest Promise Windows driver R_WinDrv_Installer_V6.2.0.6_WHQL

Both units are running latest Promise Firmware (R_SI_5.04.000061)


I have performed partition and filesystem check on both system which went successful and showed no errors.

Could you please help me, they are my work drives and I totally feel helpless and desperate.



Order By: Standard | Latest | Votes
Richard Oettinger posted this 14 March 2018

Have you tried connecting the Pegasus one at a time to see if the issue follows one of them?

Try a different Thunderbolt cable too.

If the issue persists with either one connected, then it is most likely not the Pegasus but rather some change in Windows...


  • Liked by
  • Karim El Dib
Karim El Dib posted this 14 March 2018

Thank you for your quick answer. I tried different Thunderbolt cables, and they work fine. 


But plugging the units one at a time as you suggested led me to narrow the problem to a single unit. 


It does mount and run fine on OSX without problem though, but still shows the same problem on Windows 7, contrarily to the other unit which does mount and run perfectly fine on both OS. 

I've performed both partition and filesystem check, no errors found. So the problem does seem to come from the unit, not from Windows...


Karim El Dib posted this 14 March 2018

OMG I just figured it out

It turned out there was a hidden folder called "$Recyclebin" on the drive's root which holded 125000 files in it, and it was causing Windows explorer.exe process to hang... Trashed it, problem solved

I can't believe I've lost WEEKS trying to solve this, running antiviruses and including a complete reinstall of Windows :(

Hope this will help someone else

Thank you for your help.


Richard Oettinger posted this 14 March 2018

Glad to hear you resolved it - interesting problem! 8^)