Pegasus R4 firmware update and compatibility with Mac El Capitan

  • 8.6K Views
  • Last Post 26 April 2017
  • Topic Is Solved
Ralf Hartings posted this 27 July 2016

Hi,

I run an Pegasus R4 (firmware 5.02.0000.53) and I have seen some questions/concerns on compatibility with the most recent El Capitan Mac OS. Today I run OSX Yosemite 10.10.5 without any problems.

Just want to make sure I do not upgrade and create problems...

Questions: 

1. Is my R4 compatible with Mac OS El Capitan? Is it correct I need to update the firmware?

From the SR 2.44 release notes, I understand that:

  1. - SR 2.42 provides: Bug Fixing of Mac Utility and support OS X 10.11

  2. - SR 2.44 with FW 5.04.000.57 has a new Mac SW 3.20.0000.15?

2. How do I upgrade the firmware ? (cannot find any info on this).
I have seen a new firmware SR2.44, downloaded it, but my Mac cannot handle this .img file..... 

R4 data:

serial number: M74H11812000454

Revision number: A2

WWN 2000-0001-5530-9d32 (What is WWN?)

Order By: Standard | Latest | Votes
Joe Engledow posted this 27 July 2016

In the Promise Utility click 'Promise Utility" next to the apple and click Check For Updates.

It may take several repetitions of it to work.

 

Ralf Hartings posted this 27 July 2016

Hi Joe,

 

Thanks for the quick reply!

I updated the "Promise Utility" software as you mentioned and it updated it to 3.20.0000.15 (C03).

Then I used the update function again and it found now there is an update of the firmware! Looks good! See below:

I did this, the software downloaded the FW and started installing it: 10% .... 20%  and then finished after not more then 5 sec.!

Then, as recommended, I shutdown my Mac and the R4 and rebooted everything (R4 first, then Mac). 

After rebooting, I still have the same firmware 5.02.0000.53, instead of the one (I think) I flashed  (5.04.000.57) !!!, see below:

Why is the R4 not taking the firmware update??

I repeated the whole procedure, now not shutting down the Mac, but still power-cycling/rebooting the R4, with the same result! What is wrong here?

Any hints?

Thanks!

/Ralf

Joe Engledow posted this 27 July 2016

What I've had to do is open the folder in Finder where the downloaded .img for 5.04.0000.57 is saved.

Then I open Terminal and type in promiseutil at the $ prompt then press Return, which brings up the Promise CLI (command line interface).

At the CLI I type "ptiflash -f " and before pressing Return, drag and drop the firmware .img on the Terminal window. This adds the location of the file to the command in CLI so it will look something like this: "ptiflash -f /Users/YourName/Downloads/R_SI_504000057.img".

Pressing Enter will execute the ptiflash command pointing to the 5.04.0000.57 upgrade file, and this time you will be able to watch it count all the way to 100%, and end with a direction to turn the Pegasus power off.

  • Liked by
  • Dominic Cazenove
Ralf Hartings posted this 27 July 2016

Excellent Joe! Many thanks!

This worked exactly as you say:

Ralfs-iMac:Downloads ralf$ promiseutil

-------------------------------------------------------------

Promise Utility

Version: 3.20.0000.15 Build Date: Sep 29, 2014

-------------------------------------------------------------

 

List available RAID HBAs and Subsystems

===============================================================================

Type  #    Model         Alias                         WWN                 Seq

===============================================================================

hba   1  * Pegasus R4                                  2000-0001-5530-9d32  1 

 

Totally 1 HBA(s) and 0 Subsystem(s)

 

-------------------------------------------------------------

The row with '*' sign refers the current working HBA/Subsystem path

To change the current HBA/Subsystem path, you may use the following command:

  

  spath -a chgpath -t hba|subsys -p <path #>.

 

Type help or ? to display all the available commands

-------------------------------------------------------------

 

cliib> ptiflash -f/Users/ralf/Downloads/R_SI_504000057.img 

Start transferring image, please wait ...

Flash image has been successfully transferred.

Start flashing image, please wait ...

  ... 100 percent completed...

Flash Completed.

Please shutdown or power cycle Pegasus to make new firmware take effect. This m

ay take few minutes.

 

 

cliib> 

 

-----

 

The new FW version 5.04.0000.57  is now confirmed by the Utility:

Joe Engledow posted this 27 July 2016

That's great news, Mr. Hartings. Glad I could help. Thanks for providing screenshots too. Hopefully this forum thread will help other users who are having the same problem.

  • Liked by
  • Ralf Hartings
Charles White posted this 17 August 2016

I was having the same problem and successfully updated my firmware as above.  However, now when I check for updates I receive this error message:

 

Joe Engledow posted this 17 August 2016

There may be a network error preventing your computer from accessing the Promise site where we keep the updates. Try it from other networks outside your home or office. If the problem persists, call your IT department or Internet service provider.

Charles White posted this 17 August 2016

Never had the problem before in the 3 years I have had the R4, it started immediately after I installed the firmware update.

Andreas Jaunsen posted this 24 January 2017

This procedure (manual install from CLI) works well. Thanks!!

Dominic Cazenove posted this 09 February 2017

I had the exact same problem - this solved it for me as well. Thanks Joe!

tom Reed posted this 26 April 2017

 

The screenshot (from Charles White above) shows exactly what we are getting too- with 'Please check noework connect states' - I presume that means network? It suggests it is being blocked but we cannot unblock when we are not able to see the address it is trying to access. The logs in Console show only 'Promise utility: Connect failed' Could you let us know as I am unable to update either the software or firmware. We have two Pegasus2 R4 and R6 drives running off a Mac Mini acting as a network server - these are the local backup drives in a school so are important as they have student coursework on!

Close