Pegasus 2R4 can't be seen/not mounting after upgrading to Sierra 10.12.3

  • Last Post 29 July 2019
philippe menegatti posted this 05 February 2017

drive firmware upgraded with last available release R_SI_504000057

checked Promise update, OK

drive is no more mounting and can't even be seen on my iMac running Sierra 10.12.3

issue seems specific to that last Sierra release


thanks for your suport

  • Liked by
  • B Hud
Order By: Standard | Latest | Votes
Larry Marshall posted this 24 February 2017

I am having the exact same problem.  Upgraded the OS and now the drive has disappeared.

  • Liked by
  • Richard Welter
  • B Hud
P B posted this 29 April 2017

Hi Philippe,

Have you tried loading the kernel extension?

sudo kextload /Library/Extensions/PromiseSTEX.kext

Then you can verify in the Terminal by querying the bundle ID:

kextstat | grep com.promise.driver.stex

The output should be:

47 0 0xffffff7f80f73000 0xb000 0xb000 com.promise.driver.stex (5.2.10) D5918F4B-6516-32DF-855F-E4CBE26067CD <46 12 5 4 3>

If you get the above, that means you loaded it successfully. You should also refresh System Information after you've done the above. You should see that the PromiseSTEX is loaded.

kextload man page
kextstat man page



  • Liked by
  • Pradeep Chidambaranath
philippe menegatti posted this 01 May 2017

My PEGASUS R2 is back on line !

Outstanding support from Promise team (and I'm not used to give compliments)

Many thanks Ven

Best regards, Philippe



  • Liked by
  • Pradeep Chidambaranath
Devendra Kumar posted this 05 February 2017

Hi Philippe,

We need to analyze the subsystem report to isolate the issue, please save and attach it here. 

Steps to save the subsystem report:

- Open promise utility

- Click subsystem information icon on the top of the Promise Utility window

- Click the lock symbol on the left bottom corner of the screen to unlock the utility

- Click on save service report button to save the subsystem report.

For quick assitacne please contact Promise Tech Support.



philippe menegatti posted this 23 February 2017


Forgot to mention in my post that even Promise Utility can't see the drive (no dashboard)

FYI , the drive is on line for System-info/Hardware/Thunderbolt

Drive was working fine before I update Sierra from 10.12.2 to 10.12.3. It is so specific to that new OS release

More than 1 month this drive is out of service, quite long and critical to get access to some files

Thanks for your support




Jeffrey Cederberg posted this 07 March 2017

I have a Pegasus R4, too, and I have had problems in the past with it not mounting.

This is going to sound strange -- and I haven't tested this thoroughly -- but I think the R4 Thunderbolt interface might be susceptible to RFI (radio frequency interference). 

If you are next to your Mac with your cell phone, turn it off, or move it to another room.

Unless it was pure coincidence, I seemed to have better luck with the R4 mounting when my cell phone was not in the proximity of the Mac (and more specifically, Thunderbolt). 

I wrapped aluminum foil around both hardware ends of the Thunderbolt cable for an extra measure of RF protection.  

I did NOT, however, make a tin foil hat. :D

Good luck. 

Raghuraman Kannan posted this 07 March 2017


Can you please confirm if the issue is still ongoing.

We do not have any comaptibility issues with OS Sierra and the Pegasus should mount fine.

If the issue still persists , please send us the subsystem report for our analysis.

Steps to save the subsystem report :


- Open Promise Utility

- Click subsystem information icon on the top of the window

- Click the lock symbol on the left bottom corner of the screen to unlock the utility

- Click on save service report button to save the subsystem report and attach it to this thread.

Thanks !


philippe menegatti posted this 10 March 2017



I confirm issue is still ongoing

As I already mentionned in that post and by mail I don't have access to any "subsystem information" icon when running Promise Utility. Only a restricted menu with following options:

- Promise_Utility (About, Check for Updates, Preferences, ...)

- View

- Window

- Help

Full menu with icons only showing when drive is on line. Which is not the case.



Hariprasad Velmurugan posted this 10 March 2017

Hi Philippe,

It seems that pegasus could not communicate with the host machine. please hot plug the thunderbolt cable and try with different slot then restart the pegasus as well as  MAC system and try to launch the promise utility, If still unable to launch utility. shutdown the unit lable all the drives , remove from the unit and reboot the unit with out the drives then try to launch the utility. If still The same Try with different thunderbolt cable and different Mac system. After performing the steps if you able to access the promise utility please follow the below steps.

Open the promise utility then unlock the utility

- Click on subsystem information in the pegasus utility

- Then click on save service report.




Raghuraman Kannan posted this 12 March 2017

Hi Philippe,

If the above steps do not work , then generate the report using the MAC Terminal.

Open MAC terminal and then type promiseutil and then type the following commands one at a time and save the output of the commands to a file and attach that file to this thread for our review: 

subsys -v 

enclosure -v 

ctrl -v 

phydrv -v 

array -v 

logdrv -v 


event -l nvram

Note:- In the above command " event -l nvram " it is lower case letter 'l' but not a numeric 1.


philippe menegatti posted this 17 March 2017

Hi Raghuraman

Sorry for response delays but I am overbusy

True also I am much worried about all my files not being (temporatily) not accessible

1 - done all drive cold reboot operations as per your last week email and even bought a brand new Thunderbolt cable: unsuccessfull

2 - attaches are 2 files

First one with Terminal instructions as per your last email: same statement : "subsystem not found"

More interesting I think is the second file, screen capture from "System Info" edited in // with Promise Utility 

From System Info PegasusR2 drive is connected

Hope this will help

Best regards, Philippe

Terminal Diagnostic


System Info


Venkatachalam Settu posted this 19 March 2017

Hi Philippe,

Can you power off the unit and pull all the drives out halfway leaving them disconnected but leaving them in the same slots. Power up the empty unit and execute the commands then let us know the output?

Thank you.



philippe menegatti posted this 19 March 2017

sorry Ven,  "subsystem not found"



Venkatachalam Settu posted this 20 March 2017


Have you tried using different thunderbolt cable? What is the power/thunderbolt light status of the unit after powered on empty chassis?

Could you please try the below steps and let us know the status?

- Shutdown the Pegasus unit and disconnect the thunderbolt cable from mac.

- Reboot the mac machine, connect the Pegasus unit into the mac once it's booted.

Thank you.


philippe menegatti posted this 25 March 2017

Hi Ven,

Drive working perfectly on my wyfe MacbookAir running 10.11.6 El Capitan

See screen capture here below

Was running fine on my MacbookAir and iMac before I updated to Sierra

So, clearly:

1 - not hard but a soft issue

2 - issue directly related to last Apple OS update (please have a look to my first post here above 


Thanks for your support, Philippe

philippe menegatti posted this 28 March 2017

philippe menegatti posted this 28 March 2017

Venkatachalam Settu posted this 28 March 2017


There are few support cases have been created under your promise support account and unable to reach you over the phone to work on this issue.

Please call technical support at 408-228-1500 or update the case with your availability time and call back number to proceed further.

philippe menegatti posted this 29 April 2017

Hello Ven,

last interesting info before calling tech support

found that PromiseSTEX.kext is listed in Librairy/Extensions 

but not in System Info/extensions

Promise extension required to access my Pegasus R2 drive has been so disabled at boot by Sierra 10.12.3 (and now 10.12.4)

Sure will help for your diagnostic

Regards, Philippe


Mark Koury posted this 28 June 2017

I have the same problem. After every restart the RAID drive doesn't load and is not accessible. I have found that, if after the restart is over, if I pull the plug briefly on the RAID and then plug it back in - it will then load, appear on the desktop and be functional. This started after the last firmware update. I'm running OS 10.12.5 and Firmware 5.04.0000.61

Show More Posts