Orange light on the power button and unresponsive

  • Last Post 31 July 2019
Patrick D posted this 01 August 2017

My Pegasus2 R4 unmounted and the power button turned oragne. Im using OsSierra and the promise utility doenst show any interface window. The view and windows options are grey.

I cant turn on or mount the pegasus and the utility is not working on my Sierra.

Any ideas?


Order By: Standard | Latest | Votes
Venkatachalam Settu posted this 01 August 2017

H Partick,

It looks like this issue needs to be analyzed with the help of subsystem report of the unit to find out the problem.Kindly follow up your existing case # 20170731200538S.

Thank you.

Patrick D posted this 01 August 2017

they seem to be separated issues, how come is the pegasus utility not working or showing any active interface window for the MacOSSierra?


Venkatachalam Settu posted this 01 August 2017

Hi Patrick,

There are many scenerios where you can face the Promise Utility not responding issue. I beleive it's not MacOSx issue.

Thank you.

Patrick D posted this 01 August 2017

What should I do to fix the utility? so we can start focusing on the RAID


Venkatachalam Settu posted this 01 August 2017

Hi Partick,

Kindly follow up the support case # 20170731200538S.

Thank you.


Andrew Dean posted this 01 August 2017

I am having the same issue. 

Pegasus2 R Series 8-bay enclosure with 8 x 4TB SATA HDD; PROMISE hardware RAID; Thunderbolt2™ technology; 1 meter Thunderbolt cable.

Strange thing is the system report has correctly ID'd the raid



  Vendor Name: Promise Technology, Inc.

  Device Name: Pegasus2-R

  Vendor ID: 0x2

  Device ID: 0x9

  Device Revision: 0x3

  UID: 0x000200000012AD40

  Route String: 1

  Firmware Version: 19.2

  Port (Upstream):

  Status: Device connected

  Link Status: 0x2

  Speed: Up to 20 Gb/s x1

  Current Link Width: 0x2

  Cable Firmware Version: 0.1.23

  Link Controller Firmware Version: 0.13.0


  Status: No device connected

  Link Status: 0x7

  Speed: Up to 20 Gb/s x1

  Current Link Width: 0x1

  Link Controller Firmware Version: 0.13.0




Pradeep Chidambaranath posted this 01 August 2017

Hi Andrew,

Please go to and register the product under your name and create a support ticket with the latest subsystem report for further assistance.

Follow the below step to save the subsystem report for further investigation.

- Open Promise Utility.
  - Click subsystem information icon on the top of the window.
  - Click the lock symbol on the left bottom corner of the screen to unlock the utility.   - Click on save service report button to save the subsystem report.   Regards Pradeep C

Patrick D posted this 12 December 2017

Hi I'm still with the orange light and nothing mounted to the computer. Also the Promisse app there is no display window. Any help with this? not even the promisse app is working....

Mario Cavalli posted this 27 April 2018


I'm experiencing exactly the same problem.

Installed macOS update to High Sierra 10.13.4 on return from vacation.

On restarting iMac (Retina 5K, 4Ghz Intel Core17), Pegasus Promise failed to mount, power button illuminated ORANGE, will not power down, or respond.

Have installed Promise Utility 'R_Promise_Utility_402000010', allowed extension under Security & Privacy and rebooted. Still not mounting and nothing showing in Promise Utility either.

Have submitted issue to Support Center and awaiting response but meanwhile, all my work and data is inaccessible. Uncertain how to proceed.

Any help or advice gratefully received. 


Since writing the above, I found and followed this advice:

- Shutdown the pegasus using the power button

- If it's not working unplug the power cable

- Mark and Remove all the drives from the unit

- Turn ON the unit without the drives 

- Open Promise Utility

- Click subsystem information icon on the top of the window

- Click the lock symbol on the left bottom corner of the screen to unlock the utility


- Click on save service report button to save the subsystem report.


However, having powered down the iMac, removed power cable and drives then rebooted the Mac, the unit would not power up at all, either automatically or by depressing the power button.


All connections have been checked, alternate thunderbolt ports tried at both ends, rebooted several times, with and without drives replaced always in the correct order but the unit is showing no sign of power. I am therefore unable either to use the Promise Utility or generate a service report.

A follow up question, if the fault is with the unit itself, can I purchase a replacement 4 bay unit and insert the four drives from this faulty one?



Again, thank you in anticipation.







Jeff Azoudis posted this 04 July 2018

Exact same issue for me.  Promise 2 R4 has

1) unrseponsive power button,

2) is not recognized by my imac running Sierra 10.13.5,

3) freezes certain programs but the mac quickly recovers only when I unplug the thunderbolt cable,

4) if the drive by chance becomes visible in finder no data or folders are visible in the promise, and more recnelty now

5) my second drive has a red light and has now failed.

Waiting on Promise to get back to me with support.


Geoffrey Tissier posted this 21 February 2019

Any hint regarding this issue ? I have the same problem.

I contacted the support but after a few basic suggestions like to try booting without drives or checking the TB cable, I got the generic answer like "your chassis is damaged, please get a new one"

I have the feeling it's a firmware issue or at most a tired capacitor.

I took the chassis apart, removed the top holding the main board, unplugged it from the drive board, put it on the side, leaving the rest plugged. One can notice 3 switches on the board, SW1, SW2 and SW3. SW1 is accessible from the back panel, hidden in a tiny hole. I could not find any documentation about the purpose of those switches.

I tried to boot the unit like this, leaving all the connectors except the drives board, trying random pushes of the switches, long short, different orders, while running, while unplugged…

After many trials, I COULD FINALLY GET THE UNIT TO BOOT. I got the blue light and it appeared in the promise utility.

I made the mistake to go in the drives menu which made the unit crash, as the disk board was not plugged. I was then back to the starting point and could not boot again since I don't know the combination I did to get it to boot.

I would have expected more advanced support from promise, this is a pricey device, used in a professionnal environment. Trials show that there's some hope to fix it but I get no valuable support or documentation : what do these buttons do, what's the purpose of the back RS232 connector (probably terminal access for diagnostic and low level operations), is there a hard reset switch, a safe mode boot…

Considering the complexity of the board, the numerous connectors, testing pads, jumpers and switches, there are probably several things to try before declaring it good for the trash.


M Velasquez posted this 31 July 2019

Hi all;

I have noticed that my Pegasus 3 R4 thunderbolt 3 to Thuderbolt 2 adaptor connected to my iMac 4Ghz i7 late 2014 Retina 5K will have problem powering on two daisy chained thunderbolt 3 drives. 

I also have two daisy chaned older PegausR4 thunderbolt 2 drives connected to the same iMac. Glad I have two thunderbolt ports on the machine.

The 3's will have an orange light with blue lights on the drives and the utility will not recognize the P3's It will see the older RAID just fine.

I power cycled a few times and disconnected the RAIDs to no avail. 

I had a deadline and no time to put in a ticket. I tried different restarts and shutdown combos.

I still have this problem happen but now I have a fix. 


1. power off the iMac

2. Pull the power plug out of the Pegasus3 RAID drives

3. Pull the thunderbold3 to 2 adaptor from the iMac to the RAID out of the RAID -( I leave the cable in the iMac just disconnect the RAID end. )


5. Power on the iMac (with no thunderbot connection to the RAID)

6.  Reconnect the power plugs to the RAID

7. Once the iMac is booted I plug in the cable with the he thunderbolt 3 to 2 back into the RAID 

The chirps happen and the RAID boots and the utility app launches as usual 

Hope this is repeatable and helpful for anyone in this situation.