MacOS cannot repair the disk "Promise RAID"

  • 2.3K Views
  • Last Post 25 November 2016
Jean-Pierre Krief posted this 21 November 2016

Hello everyone,

I would like to begin by thanking everyone who might take the time to read my issue and guide me to a solution.

I am an editor currently working on a movie which workflow went from FCP7 (too outdated and many compatibility issues) to Adobe Premiere Pro CC 2017. I am using a Pegasus R6 10TB as main storage and interface (all rushes, renders etc.). The disk is connected to the iMac (mid-2011, i7 3,4 GHz, 16 Go DDR3, HD 6970M, 10.12 Sierra) via Thunderbolt.

Today during a quite large render session on Adobe Premiere, the software froze and crashed. I restarted the computer with many difficulties which now prompts me "MacOS cannot repair the drive Promise RAID. You can still open or copy files on the disk but cannot save any changes made to the files".

I am aware this must be a permission issue related to the crash but tried every tip to repair the main drive permissions with no result. As a result I cannot open the project in Adobe Premiere anymore since the drive is read only. I cannot manually change the permissions. I tried a lot of workarounds but only failed.

Since then, getting quite desperate since it is impacting the valuable editing time, I tried a migration of the disk array from RAID5 to RAID0 to kind of reset the structure. What I didn't plan on was the time it was gonna take since it has been more than one hour and only 2% of progression. I have to add 7TBs are used on the 10TBs total.

I would like to know if it would be possible to

1) Cancel the disk array migration since it will be probably useless and is currently impacting the performances of my computer (as well as making a ton of noise).

2) Did any of you encounter the issue above (macOS cannot repair the disk) and have a workaround in mind.

Thank you very kindly in advance

Best regards

Order By: Standard | Latest | Votes
Hariprasad Velmurugan posted this 22 November 2016

Hi Jean,

Since you had started migration started in the unit. Its not possible to stop the migration process, moreover the process will take more than week or it will take months to complete the process.

Also you had mentioned that getting error ( Mac osx cannot repair the disk) this could be happen when pegasus filesystem corrupted in MAC osx. Need to very the logs to find out exact problem.

Open the promise utility then unlock the utility

- Click on subsystem information in the Pegasus utility

 Then click on save service report.
   
Please upload the saved subsystem report.

 

Regards

Hari

  • Liked by
  • Jean-Pierre Krief
Jean-Pierre Krief posted this 22 November 2016

Hi Hari,

First of all thank you for your swift answer and for the time you take rearding my issue.

Surprisingly, the migration is over since this morning (I just got to work).

I am uploading the subsystem report to you right now.

https://www.dropbox.com/s/80hnkd3ilfcxtph/subsysteminfo.html?dl=0

Best regards

Jean

PS : I spoke too soon, the migration is still at 20%...

Stephen van Egmond posted this 25 November 2016

Jean-Pierre-

The error message means that the OS can't, in confidence, read and write that disk.   It is forced to be mounted read-only.  I had this with an ordrinary desktop drive, not a RAID. Problem is the same.

Rescue the contents off, reformat, copy back.

 

Pradeep Chidambaranath posted this 25 November 2016

Hi Jean-Pierre,

Generally, the error means, the file system is corrupted. Pegasus unit is a raw storage and the file system is managed by MAC. If the file system is corrupted and if MAC is not able to repair then you could either back up all your data to delete and create the array or you can use DiskWarror to repair the file system.

Close