Fix for slow SMB access (smb security problem) with Mac OS X ( Vess R2600tiD and Sanlink2 10G )

  • 52K Views
  • Last Post 07 November 2016
Joris Piepers posted this 06 June 2016

Open this file: com.apple.smb.server.plist
Location: /Library/Preferences/SystemConfiguration/com.apple.smb.server.plist
Open the file with TextWrangler. (Free download at: http://www.barebones.com/support/textwrangler/updates.html)

Add this to the file:
<key>SigningEnabled</key>
    <false/>
    <key>SigningRequired</key>
    <false/>

Restart the machine.
Hope this is helpful.

  • Liked by
  • Sergiy Voskoboynikov
Order By: Standard | Latest | Votes
Jerry Lin posted this 30 June 2016

Hi Joris,

Not quite understand your question.

Could you talk more in detail?

 

Thank you

Jerry Lin

P B posted this 01 July 2016

The correct way to disable SMB Signing which is enabled by default on OS X 10.11.5 > 10.12 (Execute these instructions exactly): 

iPhilBendeck:~ philbendeck$ sudo -s
Password:
bash-3.2# echo "[default]" > /etc/nsmb.conf
bash-3.2# echo signing_required=no >> /etc/nsmb.conf
bash-3.2# exit

To check that it properly wrote the nsmb.conf file:

iPhilBendeck:~ philbendeck$ cat /etc/nsmb.conf
[default]
signing_required=no

Check if SMB signing is disabled on your share after you remount the SMB volume:

iPhilBendeck:~ philbendeck$ smbutil statshares -a 
==================================================================================================
SHARE                         ATTRIBUTE TYPE                VALUE
==================================================================================================
SD01                     
                              SERVER_NAME                   10.0.0.140
                              USER_ID                       501
                              SMB_NEGOTIATE                 AUTO_NEGOTIATE
                              SMB_VERSION                   SMB_3.0
                              SMB_SHARE_TYPE                DISK
                              SIGNING_SUPPORTED             TRUE
                              EXTENDED_SECURITY_SUPPORTED   TRUE
                              LARGE_FILE_SUPPORTED          TRUE
                              CLIENT_REQUIRES_SIGNING       TRUE
                              FILE_IDS_SUPPORTED            TRUE
                              DFS_SUPPORTED                 TRUE
                              MULTI_CREDIT_SUPPORTED        TRUE
                              ENCRYPTION_SUPPORTED          TRUE

If you see the the SIGNING_ON = TRUE Variable, that means its still on and you did not execute the instructions properly.

                              SIGNING_ON                    TRUE

This variable should not show up after you have disabled SMB signing on the OS X 10.11.5 client. This is also applicable for OS X 10.11.6>10.12 (Mac OS Sierra)

Joe Langenfeld posted this 01 November 2016

This variable should not show up after you have disabled SMB signing on the OS X 10.11.5 client. This is also applicable for OS X 10.11.6>10.12 (Mac OS Sierra)

This did not work for me.  I tried it several times.  Is there a keystroke missing or does this not work in Sierra?  It would be nice to get the 10gbe Library Share for FCP 10.3 faster over smb.  

Thanks,  Joe

P B posted this 01 November 2016

Hi Joe,

"This did not work for me.  I tried it several times.  Is there a keystroke missing or does this not work in Sierra?  It would be nice to get the 10gbe Library Share for FCP 10.3 faster over smb." 

This is applicable to macOS Sierra. I have prescribed this solution multiple customers.

1. Did you follow the instructions exactly and executed the above as root?
2. Did you remount the volume after the changes?
3. When you ran the command:

 smbutil statshares -a

Does the SIGNING_ON variable equate to TRUE? It should not show up if the instructions were followed properly.

4. Have you benchmarked the speed of the SMB share before and after the changes? If so, what R/W speeds did you get?

If you need further assistance, please open a case at https://support.promise.com

KB Article on Disable SMB Signing
Disable SMB Signing on OS X (10.11.5 > 10.12.x)

Regards,

</Phil>

Drew Saur posted this 07 November 2016

Hi Joe,

"This did not work for me.  I tried it several times.  Is there a keystroke missing or does this not work in Sierra?  It would be nice to get the 10gbe Library Share for FCP 10.3 faster over smb." 

This is applicable to macOS Sierra. I have prescribed this solution multiple customers.

1. Did you follow the instructions exactly and executed the above as root?
2. Did you remount the volume after the changes?
3. When you ran the command:

 smbutil statshares -a

Does the SIGNING_ON variable equate to TRUE? It should not show up if the instructions were followed properly.

4. Have you benchmarked the speed of the SMB share before and after the changes? If so, what R/W speeds did you get?

If you need further assistance, please open a case at https://support.promise.com

KB Article on Disable SMB Signing
Disable SMB Signing on OS X (10.11.5 > 10.12.x)

Regards,

</Phil>

Phil,

I can confirm that my /etc/nsmb.conf file contains:

[default] 

signing_required=no

...and any SMB shares I mount show:

                               SIGNING_SUPPORTED             TRUE

but do not show SIGNING_ON. However, my speeds are still less than ideal. I am not sure what else to do. I have been trying to fix this for months, to no avail.

P B posted this 07 November 2016

Hi Drew,

The variable:
 
SIGNING_SUPPORTED             TRUE

This only signifies that SMB Signing is supported by the SMB server that hosts your shares.

1. What storage are you using for your SMB share(s)?
2. Does your 10Gb SANLink connect to a VLAN?
3. What are the R/W speed metrics that you're receiving and what disk speed tool are you using to determine the speed?

Apple prescribes the same solution as the forum above:



Regards,

</Phil>

  • Liked by
  • Vida Vrojonnson
Close