ESXi support

  • 2.6K Views
  • Last Post 14 December 2016
Matt Dri posted this 23 September 2016

Are any of the Pegasus2 thunderbolt devices compatibile with VMWare ESXi 6?  Will they appear as a datastore?  Is the RAID controller supported?

Order By: Standard | Latest | Votes
Venkatachalam Settu posted this 23 September 2016

Hi,

We have not tested Pegasus2 with VMware ESXi environment.

Please refer the compatibility list using below link:

http://promise.com/DownloadFile.aspx?DownloadFileUID=4126

The compatibility sheet has the list of current qualified and supported compatible products. If it is on this list then it has been tested and approved for use. If it is not on this list then it is not officially supported i.e. it has not been tested, it may or may not work.

Thanks.!

 

Matt Dri posted this 28 September 2016

Thanks for the prompt reply.  Can I ask what raid controller(s) is being used in the Pegasus2 R4/R8?

 

Todd Epple posted this 14 December 2016

Are any of the Pegasus2 thunderbolt devices compatibile with VMWare ESXi 6?  Will they appear as a datastore?  Is the RAID controller supported?

Hi Matt,

Not sure if you are still interested but I got the Pegasus R6 Thunderbolt to work on a Mac mini with my ESXi 6.0 by installing the scsi-stex-4.07.0000.75-1OEM.500.0.0.472560.x86_64.vib file that you can download from http://www2.promise.com/media_bank/Download%20Bank/Drivers/

Even though the driver is dated 2011 and was written for the SuperTrax ES SAS RAID device it worked great on ESXi 6.0 with the Thunderbolt Pegasus RAID device attached to a Mac.

That said, I'm having no such luck using the same .vib file on my new ESXi 6.5 install as it's too far out of date at this point.  I am getting this error when attempting to install it:

 [DependencyError]

 VIB Promise_bootbank_scsi-stex_4.07.0000.75-1OEM.500.0.0.472560 requires com.vmware.driverAPI-9.2.0.0, but the requirement cannot be satisfied within the ImageProfile.

 VIB Promise_bootbank_scsi-stex_4.07.0000.75-1OEM.500.0.0.472560 requires vmkapi_2_0_0_0, but the requirement cannot be satisfied within the ImageProfile.

In researching tonight it seems many old .vibs are suffering from the same deprecated drivers but if you stay on 6.0 you may be lucky.

Hope this helps.

Close