Cannot Downgrade NS2600

  • Last Post 19 April 2020
Matthias Böhm posted this 05 December 2017



I have a Problem with my NS2600 NAS,


With the latest Firmware it ist not possible to create an iSCSI Volume over the whole Raid.

Only 10% is automatically assigned to iSCSI on the Raid Volume.


With the FW 02.01.0000.18 it worked fine.


Now i cannot downgrade with Safe Mode. I always get the Message "Invalid Upgrade File". I have tried to downgrade with all firmware files I found on the hompage. No Success.


Also this Tutorial is not working:

I cannot upload a File on the public folder, i just can upload the file directly on Safe Mode.


I know this is a old NAS, but for my backup this would be good enough.


But on CIFS I get a write performance about 6 MB/S. On iSCSI about 20 MB/s.


Maybe someone can help me


Thank you!


Order By: Standard | Latest | Votes
Tomisalv Kobal posted this 19 April 2020

hi frends, did you solve the problem with ns2600? I have the same problem, stuck in safe mode and unable to upload the new original firmware, can you help me? i have no firmware backup and i dont know if the aboand i dont know if the above was original

Matthias Böhm posted this 07 December 2017

Hi Richard,


thank you for your testing.


Now I know that I am not too stupid to flash this firmware ;)


I will now copy my backup files with cifs. This is 4 times slower but it works ;)


Thank you once again!

R P posted this 07 December 2017

Hi Matthias,

My workaround was not successful, so I won't post it here.

Unfortunatly this product is long EOL so I can't file a bug against it. There's nothing more I can do.

R P posted this 06 December 2017

Hi Matthias,

You are right, the procedure does not work here. I located an NS4600 and tried to use it. The problem is that in safe mode the NS4600 only allocates about 40MB to the public folder, that is not enough room to upload the 112MB v02.01.0000.18 firmware file. The original firmware file was only 27MB, so this probably was a design decision.

I have a potential workaround in mind, but I will need to test it.

Matthias Böhm posted this 05 December 2017

You can see in this tutorial that yiu have to enter a filename and then the promise shod start flashing.. 


I have already copied the file to the directory but I cannot enter a filename in Safe Mode.


I can just click at a button named "File Upload"  abd then I can upload a file with my browser. 


This Tutorial is not working with NS2600..


Thank you

R P posted this 05 December 2017

Hi Matthias,

After you enter the public folder you can drag and drop the file into the folder. Either that or right click on the firmware file, seclect copy, then in the public folder right clock and select paste.

I don't really understand what step is failing and how is it failing, can you describe it or upload a screenshot?

Matthias Böhm posted this 05 December 2017

Hi  thanks for your reply. 


This doesn't work. 


I cannot enter a filename, either Upload a file. 


I tried to upload a file in normal mode. This doesn't work either.. 

R P posted this 05 December 2017

Hi Matthias,

I do not have an NS2600 to test with but looking at the KB I see an error.

Step 4 is wrong.

Open a browser and enter: \ipaddress (example: \

It should be...

Open a browser and enter: \\ipaddress (example: \\

Note the double backslashes before the IP address. This is how you connect to an SMB drive in Windows. Try this and see if you can copy the firmware to the public folder.