spath -a chgpath -t hba -p 2 has no effect

  • 450 Views
  • Last Post 06 May 2020
Daniel Drucker posted this 08 April 2020

I have two daisychained Pegasus2 R8.  I'd like to use promiseutil to look at both of them, but spath -a chgpath is not having any effect:

Note that no matter whether I specify -p 1 or -p 2, the first one stays selected:

cliib> spath
===============================================================================
Type  #    Model         Alias                         WWN                 Seq
===============================================================================
hba   1  * Pegasus2 R8                                 2000-0001-555a-1f5f  2
hba   2    Pegasus2 R8                                 2000-0001-555e-690b  1

Totally 2 HBA(s) and 0 Subsystem(s)

cliib> spath -a chgpath -t hba -p 2

cliib> spath
===============================================================================
Type  #    Model         Alias                         WWN                 Seq
===============================================================================
hba   1  * Pegasus2 R8                                 2000-0001-555a-1f5f  2
hba   2    Pegasus2 R8                                 2000-0001-555e-690b  1

Totally 2 HBA(s) and 0 Subsystem(s)

cliib> spath -a chgpath -t hba -p 1

cliib> spath
===============================================================================
Type  #    Model         Alias                         WWN                 Seq
===============================================================================
hba   1  * Pegasus2 R8                                 2000-0001-555a-1f5f  2
hba   2    Pegasus2 R8                                 2000-0001-555e-690b  1

Totally 2 HBA(s) and 0 Subsystem(s)

 

Order By: Standard | Latest | Votes
Daniel Drucker posted this 09 April 2020

I have also tried the undocumented -P flag, to no effect.

R P posted this 09 April 2020

Hi Daniel,

There was a new Promise Utility released for the Pegasus 2 (in the legacy section) on 3/17/2020. Please give this a try.

https://www.promise.com/DownloadFile.aspx?DownloadFileUID=6416

Also a few questions.

1. Which macOS, is this Catalina?

2. Are you connecting through a TB2 to TB3 adapter?

 

As a side note, there is also a firmware update available, but as far as I know this is a Promise Utility issue and is not firmware related.

Daniel Drucker posted this 09 April 2020

Before I do the Promuse Utility update - since this is a production machine and changes require some planning - the answers are:

1) Mojave

2) Yes, I am.

Does that make a difference?

R P posted this 13 April 2020

Hi Daniel,

Another question, can you access both P8s from the Promise Utility GUI?

If there is a bug, it can only be filed against the latest released Promise Utility, and it may have been fixed in the latest utility as well, but updating the utility is the first step.

Daniel Drucker posted this 14 April 2020

Aha! Well, that's embarassing. I updated the software with the link you gave me and now both issues have gone away - I can use the 'spath' command *and* the -P flag.

 

Thanks!

 

Dennis Levens posted this 06 May 2020

I am running the latest utlity v4.04.0000.40 (C6) and I cannot change paths to HBA 2

I run spath -a chgpath -t hba -p 2 and it does not change to 2. 

 

R P posted this 06 May 2020

Hi Dennis,

What is your configuration?

* How many Pegasus2 units and what type?

* What is your OS?

* Can you see the units from the Promise Utility GUI?

Also, can you type

spath

into the CLI (type promiseutil from a terminal) and post that here?

Close