Setting the SMARTPollingInterval

  • 58 Views
  • Last Post 29 January 2020
Daniel Larsson posted this 22 January 2020

I've had problems with disks dying suddenly, with the result that the unit and the GUI stops responding. The trouble is, that I never get any heads up of the disk going corrupt. I checked the settings using the command line interface and found that the parameter SMARTPollingInterval is set to 2160000 minutes. That is every 4 year! How can I change the SMART polling interval?

cliib> subsys -v

-------------------------------------------------------------------------------
Alias: 
Vendor: Promise Technology,Inc.        Model: Pegasus2 R6
PartNo: F29DS6722000000                SerialNo: N/A
Rev: B3                                WWN: 2000-0001-5557-ec5c
CBSN: M92L14201700407                  Interface: Thunderbolt
cliib> ctrl -v

-------------------------------------------------------------------------------
CtrlId: 1
Alias: 
OperationalStatus: OK, BGA Running     PowerOnTime: 1 hour 50 minutes
LUNAffinity: N/A                       LunmappingMethod: WWN Based
CacheUsagePercentage: 0%               DirtyCachePercentage: 0%

Vendor: PROMISE                        Model: Pegasus2 R6
PartNo: F29DS6722000000                SerialNo: N/A
HWRev: B3                              WWN: 2000-0001-5557-ec5c
CmdProtocol: SCSI-3                    CBSN: M92L14201700407
MemType: DDR2 SDRAM                    MemSize: 512MB
FlashType: Flash Memory                FlashSize: 8MB
NVRAMType: FRAM                        NVRAMSize: 128KB
BootLoaderVersion: 5.04.0000.62        BootLoaderBuildDate: Nov 2, 2018
FirmwareVersion: 5.04.0000.62          FirmwareBuildDate: Nov 2, 2018
SoftwareVersion: 5.04.0000.62          SoftwareBuildDate: Nov 2, 2018
BIOSVersion: 5.04.0000.62              BIOSBuildDate: Nov 2, 2018
SingleImageVersion: 5.04.0000.62       SingleImageBuildDate: Nov 2, 2018
CtrlCPLDVersion: 6.08

DiskArrayPresent: 1                    OverallRAIDStatus: Critical
LogDrvPresent: 1                       LogDrvOnline: 0
LogDrvOffline: 0                       LogDrvCritical: 1
PhyDrvPresent: 6                       PhyDrvOnline: 5
PhyDrvOffline: 0                       PhyDrvPFA: 0
GlobalSparePresent: 0                  DedicatedSparePresent: 0
RevertibleGlobalSparePresent: 0        RevertibleDedicatedSparePresent: 0
RevertibleGlobalSpareUsed: 0           RevertibleDedicatedSpareUsed: 0

WriteThroughMode: No                   MaxSectorSize: 4KB
PreferredCacheLineSize: 64 KB          CacheLineSize: 64 KB
Coercion: Enabled                      CoercionMethod: GBTruncate
SMART: Enabled                         SMARTPollingInterval: 2160000 minutes
MigrationStorage: DDF                  CacheFlushInterval: 3 second(s)
PollInterval: 15 second(s)             AdaptiveWBCache: Disabled
ForcedReadAhead: Disabled

PowerSavingLevel: 3                    SpindownType: All drives
IdleTimeToParkRwHeads: 30 minutes      IdleTimeToLowerRotationSpeed: 2 hours
IdleTimeToSpinDown: 2 hours 30 minutes

SGPIOBackPlane: Default/Generic (0)    SASReadyLED: Off
SpinUpDelay: 0 millisecond             PowerManagement: Enable

SecurityAdminPassword: N/A

PciFuncAddr: N/A                       PciLinkSpeed: N/A
PciLinkWidth: N/A

 

 

Order By: Standard | Latest | Votes
Raghuraman Kannan posted this 27 January 2020

Hi Daniel,

Please save the service report from the Utility and open a case at https://support.promise.com/ . 

We will review the logs and will advise you on the next step.

Thanks !

Daniel Larsson posted this 29 January 2020

Alright, I've filed a support ticket.

Daniel Larsson posted this 29 January 2020

So, for future reference , the setting is hidden in a place called Component List reached from the menu item Device.

Top menu => Device => Component List => Controller . . . => Settings => SMART Polling Interval

Close