Remove old RAID config data from drive

  • Last Post 20 June 2023
  • Topic Is Solved
Nick Kay posted this 17 June 2023

I have (what is _now_) a cold spare drive that was previously used as part of a test raid group a long time ago...and that raid group no longer exists, so there is no actual data on this drive at all, aside from the old / stale RAID config data

I wish to use this drive again to rebuild a group that failed over the weekend, but I can't figure out how to wipe the previous raid config data from the drive so that it can actually be used for the rebuild.

Can someone please help me with this?  I can't believe this is so hard, lol.

There has to be a one line CLI command to wipe the old RAID config, you'd think anyway?

Order By: Standard | Latest | Votes
R P posted this 19 June 2023

Hi Nicholas,

Please shutdown the Pegasus, remove or unseat all the drives, and insert just the drive in question. Reboot the Pegasus and start the CLI by opening a terminal and entering promiseutil.

From the CLI enter the following command.

array -a del -d 0

This assumes that the array  ID is zero. If the command gives an error use the array command to find the correct array ID

cliib> array
DaId Alias     OpStatus      CfgCapacity FreeCapacity   MaxContiguousCapacity
0              OK            8.19TB      0Byte          0Byte

And use that array ID in the delete command.

Then shutdown the Pegasus and reinsert the other disks and reboot without the disk you just cleared. You may have to accept the incomplete array after rebooting. From the CLI the command is.

array -a accept -d 0

Then hotplug the drive you just cleared and a rebuild should start.

Nick Kay posted this 20 June 2023

You're amazing!  I tried asking email support how to do this all day yesterday and they just would not tell me!