R8 Firmware Update CRC Error

  • Last Post 20 March 2023
  • Topic Is Solved
Ben Milelr posted this 27 June 2022


I have a poorly performing Pegasus 2 R8 unit that I am trying to troubleshoot. A colleague reconfigured it from Raid0 to Raid5 earlier this year. When I attempt to configure it back to Raid0, I am getting extremely poor performance - erratic r/w speed compared to how it was originally performing before being switched to Raid5.

Disk health appears to be all OK. In an attempt to fix, I downloaded the most recent firmware but am getting a CRC error when I try to execute the firmware upgrade. I tried to update via CLI, but hit the same CRC error. I tried different versions of the firmware - including the original 2015 firmware already on the Pegasus - but still the same error.

I have attempted this upgrade on a 2020 Intel iMac running Big Sur. 

Any advice on how to bypass this CRC error would be appreciated. Thanks.

Order By: Standard | Latest | Votes
R P posted this 27 June 2022

Hi Ben,

You may have a drive issue, it's not possible to tell.

Regarding the firmware update issue please update to the latest Pegasus32 Promise Utility, it is backwards compatible with the Pegasus 2. This may help.

Ben Milelr posted this 28 June 2022

Hi - 

I was able to flash the firmware using a different Mac. I did not try the updated Utility on the first Mac, but it probably would have solved my problem. 


R P posted this 21 October 2022

Hi Ben,

Just an FYI. After investigation it turns out that there is an issue with the latest Pegasus32 Promise Utility (4.06.0000.04) and it will give a CRC error when attemptin to update firmware on the Pegasus2. This will be fixed next Promise Utility release, but the workaround is to use an earlier version of the Promise Utility. Version 4.06.0000.01 has been tested and works when updating firmware on a Pegasus2.

W H posted this 20 March 2023


Having the same CRC error trying to update the firmware of a Pegasus2 R6 wiht Promise Utility 4.06.0000.04.   Fails with CRC error.  Fails using terminal.  I did what was suggested here and reverted back to Promise Utility 4.06.0000.01.  The problem is that when you use check updates, the first and only item that shows up is an upgrade to 4.06.0000.04, which is proven not to work,  The firmware update is not shown. The solution is to revert to 4.06.0000.01, manually download the firmware file, and thengo into terminal and type below.  This took many many hours to figure this out.  Had to piece several different posts,

ptiflash -f [path to img file]



R P posted this 20 March 2023

Hi W H,

You can update firmware from the Promise Utility as well, as mentioned previously, go to the promise downloads page and manually download the firmware file. To update firmware, unlock the Promise Utility and navigate to the Admin tab on the top bar, 'firmware update' is one of the options.

The CLI is also great, you can click on the firmware file in finder and drag that to the CLI and it will insert the file name with the full path.