R6 Pegasus 32 intermittently mounting

  • 204 Views
  • Last Post 28 June 2023
David Gibson posted this 26 June 2023

Up until last week my two year old R6 24TB 32 Promise Pegasus was mounting on an Intel iMac running Monterey without issue. Then I moved it... about 2 feet away and I was very careful with it and didn't drop it or bang it.

So this morning it wouldn't mount on the iMac. I unplugged it and moved it onto a different part of my desk and connected it to my MBP laptop and after much plugging and unplugging the TB cable and power cable it mounted. 

No errors or anything.

So I unplugged it and plugged it back into the iMac and it mounts on the iMac. I then power everything off and it doesn't power up on restart.

I then unplugged power ejected the drives and reseated them and connect power and TB and it mounts again...

computer restart and no dice, it wouldn't mount.

I also have a R4 Pegasus 3 that is mounting like a champ everywhere I plug, intel iMac, Intel MBP and M2 Ultra Mac Studio.

The Pegasus 32 take multiple power cycles or hard drive reseating as described to mount on any of these three computers.

Pretty sure it's not a driver issue as it was working just fine on that iMac until I moved it.

Thinking it might be something more mechanical maybe? I was going to take a look inside incase it's clogged with dust or something like that.

Any other ideas or experiences I'm all ears if anyone has had a similar problem.

 

Order By: Standard | Latest | Votes
David Gibson posted this 28 June 2023

That would be too easy... and it was the first thing I tried :) swapped out cables, swapped out power cable, swapped out power outlets.... same random issues...

What I did do was take the shroud off and give everything an inspection in side, it looked pretty clean, bit of dust on the fan but that was it, took out the drives made sure all the internal cables were seated and weren't loose. All was solid.

Put it back together and it worked first time. Now I should mention that I had the R4 Pegasus3 sitting on top of the R6 Pegasus32 and after opening up the 32 I could see that the PCB is located at the top of the box.. so I wondered if the weight of the R4 on top was causing the PCB to bend... so I put the R4 back on the table and the the R6 worked and then stopped again...

So as a final 'tear my hair out' option I placed the R6 on the desk, back where it originally was... and its working predictably, at least the last 3 times I checked yesterday...

I'm going to leave it there and see what it does... it makes no sense but right now its working again...

R P posted this 28 June 2023

Hi David,

It sounds like there is an issue with the Thunderbolt cable.

Can you try the TB3 cable you use with the Pegasus 3?

Close