R4 strange behaviour on Mac OS 10.14 - warning to others

  • 83 Views
  • Last Post 13 May 2021
Andrew Pease posted this 12 May 2021

I have a legacy R4 thunderbolt array that I am supporting for a client of mine. After many weeks of frustration with it, I wanted to share my experience to hopefully help others who might end up in the same situation.

My R4 is currently setup with 4 x Western Digital enterprise gold 8 TB SATA hard drives. These were correctly identified by the Promise Utility and show no errors on SMART diagnostics. I can successfully create any valid RAID volume I like.

My issue, which I experienced with multiple sources, in many different RAID configurations was this: The array would properly build and format. The Mac OS would correctly initialize the resulting volume and would repeatedly pass Disk Utility tests for errors and consistency.

However, if I copied more than 4.2 TB of data to the volume, no matter the configuration of the array, I would start getting input/output errors. If the volume was dismounted or checked/repaired with disk utility, the volume would break and the OS would ask to initialize the disk (all data lost).

Now, I realize only 4 TB drives are rated for this system and that the software is only certified to Mac OS 10.12 (though on the forum that restriction is contradicted sometimes). My point here is that if you are using drives not on the compatibility list, and it appears to be working fine, there is a risk that you could get a nasty surprise, with little or no warning, that could seriously jeapordize your data.

Currently I am doing one final test before I give up on this hardware entirely. I have configured the array to simply pass through all drives and use the Mac OS to creat a RAID 10 array of the 4 x 8TB drives to one 16 TB volume. I am running the same data copy test and see if it dies at the same place. If not, then I know it is definitely a driver/hardware issue.

Cheers!

Andrew

Andrew Pease posted this 13 May 2021

Follow up to this post: Success!

Using the Mac OS built in software RAID on drives in my Promise Pegasus R4 that were all configured to be pass-through has not exhibited any issues. Copied 5.2 TB and counting with no problems...

I would propose that if you have legacy RAID units like this that are still functional, you could get many more years of service out of the enclosure by disablling all the hardware RAID systems and either using the drives separately or using a software RAID solution. From a performance standpoint, I cannot say if there would be an impact by using software-based RAID as I have not done any testing, but I will take an performance hit in order to assure safety of my data!

Close