R4 makes Windows 11 freeze

  • Last Post 09 November 2023
Andrey Nikolaev posted this 27 January 2022



Windows 11 Pro

Version 21H2

OS build 22000.469

Motherboard: Asus Deluxe x299 ii

Connection: Apple TB2 - TB3 connector


I have two issues

1. Pegasus2 R4 (latest firmware) ocasionaly freezes and makes the whole system freeze. Power button won't work and even unpluging thunderbolt cable won't turn the drive off. I have to unplug power cable and make a hard restart for my PC. I replaced Apple thunderbolt connector a month ago, it didn't help. 

2. Hot plug in doesn't work anymore, even though it used to work in the past. 

Subsystem reports are here: (one without HDDs, one with)




Order By: Standard | Latest | Votes
Gautham Sakthi posted this 30 January 2022

Hello Andrey,

Have you tried using another thunderbolt cable ?

Also try swapping the ports on the unit for connection.

brian lawson posted this 24 June 2022

 Hey Andrey,

I can't seem to get my new PC to see the Pegasus2 R4.  I'm using the same Apple adapter as you.  Works fine with my MacPro but keeps shutting down when I conntect to the PC (no signal, like I shut the PC off).  WebPAM_PRO is running.

Did you run into any issues using the PC RAID files from Promise? 

Thanks for any input!



Windows 11 Pro

Motherboard: Corsair

Connection: Apple TB2 - TB3 connector


Wackyou Jr posted this 09 November 2023

When dealing with hardware issues like the Pegasus2 R4 causing system freezes, it can be quite a puzzle to solve. Have you considered looking into a Windows 11 Pro retail key to ensure that your OS is fully up to date and optimized for your setup? It might help with compatibility issues.

As for the hot plug not working, it's odd that it used to and now doesn't. Have you tried checking for driver updates or reaching out to the Pegasus support team for guidance?