Promise Utility won't start

  • Last Post 13 October 2020
Sjoerd de Vries posted this 26 October 2018

Hello I am user of PegasusR4 3 on iMacPro on mac 10.13.6. And I wanted to update the newe firmware fo my Pegasus.

First I download the Promise Utility trough the update in de File menu of the app. But after restarting the app won't start, keep getting a spinning wheel (not the 'spinng off dead' from the macOS)

And then I downloaded it from the website and after install en start I do get the same result. Just a window with Pegasus 3 R4 in stiop blank window with spinngen wheel and Loading....

and an the understie "Click the lock to make changes." I can click to open the lock, adn then the lock icon is showing.

What is wrong?



Sjoerd de Vries


Order By: Standard | Latest | Votes
arunkumar b posted this 26 October 2018

Hi Sjoerd,

We are sorry for the inconvenience caused to you. Please let me know the utility version installed in your computer

Here is the link to download the latest version of Pegasus3 Series Utility for Mac

-Uninstall the utility(Move the App to Trash)

-Restart the computer and the Pegasus

-Download and reinstall the utility to see if you can open

If still same issue, please open a support case in to assist you better




Sjoerd de Vries posted this 27 October 2018

Hello Arun,


I treid the steps but still the spinning wheel and Loading....

I tried to login with support but that doesn't work, it keeps saying 'Use a valid e-mail adres'

I was using version 402..17

I also did try version 402..12 (SR3.0.8) and that one works!

Version 402..17 (SR3.2) does this version need macOS 10.14? (Because I am on 10.13.6, which I will staying on until Boris FX update there software) 

Can I update to the newest firmware with this Ulitity?


I think I need to update the firmware because the Pegasus won't go to sleep en the iMacPro is put in sleep. And the Pegasus is direct connected to the iMacPro


I am on FW 6.00.0000.12

And the file I have downloaded (not installed yet) is R_SI_600000031

Tomas Egger posted this 13 October 2020

Ola my friends,

I tried these simple steps and Its working now:

- Please move the promise utility to trash, and empty the trash. 

- Then download the latest promise utility software

- Once after installing the promise utility, Restart the unit and the mac, first turn off mac and then turn off the pegasus wait for 2 minutes and then turn on the mac and wait until it is fully booted then turn on the pegasus and wait for 2 to 3 minutes and then try to launch the utility, see if it works.

- Working fine for me now.