Promise Utility won't launch

  • 492 Views
  • Last Post 6 days ago
Jordan Beard posted this 24 September 2018

Everytime I try to open Promise Utility on my iMac (10.13.6) the top menu bar appears showing that the program has launched but I can't get the program window to appear. Does anyone know what the solution might be? I've already tried reinstalling Promise Utility. I'm using a Pegasus2 r6. Thanks. 

Order By: Standard | Latest | Votes
Ranjith kumar posted this 25 September 2018

Hi Jordan,

Could you let us know the current version of Promise utility running in your iMac?

Click on About Promise utility near Apple icon to know it.

 

Regards,

Ranjith

 

Jordan Beard posted this 25 September 2018

It's version 4.02.0000.17 - I believe it's the most recent version because I just reinstalled it

Ranjith kumar posted this 25 September 2018

Hi Jordan,

Yes, 4.02.0000.17 is the latest version of Promise utility.I think it's OS compatible issue making not launching the latest version. Kindly try with installing the 4.02.0000.12 version of Promise Utility using below link:

https://www.promise.com/DownloadFile.aspx?DownloadFileUID=4854

If you still facing an issue, kindly login at support.promise.com and create a web support case to help you further.

 

Regards,

Ranjith

Tomas Egger posted this 6 days ago

Ola my friends,

I tried these simple steps and Its working now:

- Please move the promise utility to trash, and empty the trash. 

- Then download the latest promise utility software

- Once after installing the promise utility, Restart the unit and the mac, first turn off mac and then turn off the pegasus wait for 2 minutes and then turn on the mac and wait until it is fully booted then turn on the pegasus and wait for 2 to 3 minutes and then try to launch the utility, see if it works.

- Working fine for me now.

Thanks

Tom

Close