Promise Utility Window Won't Open

  • Last Post 23 May 2019
Matt Palmer posted this 23 May 2019

I'm on Mac Mojave, however had the same problem with High Sierra. The disc utility window will not open, promiseutil hangs as well. I've already contacted support to no avail. I've tried every version of the disc utility, same problem. I would appreciate a solution to this other than we can't help you. Clearly there are others with this same problem.



Order By: Standard | Latest | Votes
P B posted this 23 May 2019

What version of the Promise Utility are you using?

Matt Palmer posted this 23 May 2019

I've currently got 4.02.0000.21 installed, however I've tried installing every previous version.

P B posted this 23 May 2019

Version 4.02.0000.21 is supported in macOS Mojave.

$ mdls -name kMDItemVersion /Applications/Promise\
kMDItemVersion = "4.02.0000.21"

$ sw_vers ProductName: Mac OS X ProductVersion: 10.14.5 BuildVersion: 18F132

Do you know if the kernel Extension is loaded:

$ kextstat | grep 'com.promise.r2p.icon\|com.promise.driver.stex'
  109    0 0xffffff7f80f69000 0x4000     0x4000     com.promise.r2p.icon (1.0.10) 1245CB93-214E-3E2D-A291-D9546D4920EA <29 28 13 5 3>
  187    0 0xffffff7f80cfb000 0xd000     0xd000     com.promise.driver.stex (6.2.9) A98F7D05-34D3-3B2B-9EE4-C5AC7494B2A8 <107 13 6 5 3

If the the above kextstat syntax is blank, please load the (2) kernel extensions and see if that allows you to interact with your Pegasus.

sudo kextload -b com.promise.r2p.icon
sudo kextload -b com.promise.driver.stex

If they're loaded and still unable to interact with the Pegasus via Utility or promiseutil, you can try to manually uninstall the Promise Utility and reinstall from scratch:

1. Unmount your volume(s) first.
diskutil unmount /Volumes/NameOfVolume1

2. Unload and Delete the kernel extension:
sudo kextunload -b com.promise.r2p.icon
sudo rm -rf /Library/Extensions/Pegasus2R2ICON.kext
sudo kextunload -b com.promise.driver.stex sudo rm -rf /Library/Extensions/PromiseSTEX.kext
3. Delete the Pegasus Utility: sudo rm -rf /Applications/Promise\
4. Delete the Promise Utility plist: sudo rm -rf /Users/'$myUser'/Library/Preferences/com.promise.PromiseUtility.plist
5. Delete the LaunchDaemons plist files: sudo rm -rf /Library/LaunchDaemons/com.promise.emaild.plist sudo rm -rf /Library/LaunchDaemons/com.promise.bgasched.plist sudo rm -rf /Library/LaunchDaemons/com.promise.BGPMain_R.plist sudo rm -rf /Library/LaunchDaemons/com.promise.diskmonitor.plist
6. Delete promiseutil (The Promise Utility installer pkg will re-install this): sudo rm -rf /usr/local/bin/promiseutil
7. Restart the machine.
8. Install the Pegasus 6.2.9 driver and the Promise Utility.
9. See if that shows the stats for both Pegasus via GUI and CLI.

Matt Palmer posted this 23 May 2019

Thanks for this. This is the closest we've gotten to a solution. I followed your steps and tried again. When the disk is unmounted, neither the GUI or CLI hangs, however there is still no window that opens with the GUI. When I mount the drive, the GUI and CLI both hang and do not open.

P B posted this 23 May 2019

Please open a case at or call (408) 228-1500