Promise Utility - Searching for Pegasus Devices...

  • 142 Views
  • Last Post 16 December 2021
Jerry Chan posted this 29 October 2021

I've already opened a support ticket for this, but wondering if anyone else is running into the same issue. Promise Utility is not recognizing any of the units I have plugged into my system. I have an R4 and R6. Launching Promise Utility opens two new windows—one for each device—but both have the spinning icon and "Searching for Pegasus Devices..." message and never updates. I can access the contents of both devices, but I have no access to Promise Utility features like updating firmware or viewing status updates.

MacOS 11.6.1
Promise Utility v 4.06.0000.01 (C02)

Order By: Standard | Latest | Votes
Keith Goetz posted this 15 December 2021

I seem to have that problem too.

The disks in my R6 box all seem fine.  They are accessible to macOS.

Running the Promise Utility (which I admit, I do only rarely) usually works just fine but now just produces the spinning icon.

 

macOS 10.15.7

Promise v 4.04.0000.42

R P posted this 16 December 2021

Hi,

I had the same issue this morning. It was solved by quitting the Promise Utility (from the Promise Utility button in the top bar) and re-starting it.

One interesting fact is that the CLI is seperate from the GUI promise Utility. This means that you should be able to open a terminal and type 'promiseutil' and manage the Pegasus from there even if the Promise Utility is not accessible for some reason.

Close