Promise Utility running but application window is not displayed

  • 304 Views
  • Last Post 06 February 2021
Buzz Smith posted this 30 January 2021

I bought a Pegasus2 R4 with no hard drives. I downloaded and ran the Promise Utility (on MacOS 10.13.6) and was going through the setup and checked the driver version. There was a new version available, so I updated the drive and it successfully flashed the Pegasus. Once the Mac was rebooted, the Promise Utility no longer displays anything. It is running. I can see it on the header bar and dock of the Mac, but no interface for me to use. I cannot setup the RAID array, so I am dead in the water. Any ideas? I have deleted the Promise Utility and reinstalled it. I have rebooted the Mac. Nothing is working.

Order By: Standard | Latest | Votes
Gautham Sakthi posted this 06 February 2021

Hi Julien Jean-Pierre,

 

What is your MAC OS Version?

 

You coun download the drivers and utilities by going to https://www.promise.com/Support/downloadcenter

Julien Jean-Pierre posted this 06 February 2021

Is it possible to explain where you went to get the older driver and software? I am having the exact same issue.

 

Thanks

 

Julien

 

 

Pegasus R-Series:

 

  Vendor Name: Promise Technology, Inc.

  Device Name: Pegasus R-Series

  Vendor ID: 0x2

  Device ID: 0x1

  Device Revision: 0x1

  UID: 0x00020000000D5AA0

  Route String: 1

  Firmware Version: 22.3

  Device Micro Firmware Version: 1.0.0

  Port (Upstream):

  Status: Device connected

  Link Status: 0x2

  Speed: Up to 10 Gb/s x2

  Port Micro Firmware Version: 1.4.14

  Cable Firmware Version: 1.0.16

  Cable Serial Number: C4M3314035NF798AH

  Port:

  Status: No device connected

  Link Status: 0x7

  Speed: Up to 10 Gb/s x2

  Port Micro Firmware Version: 1.4.14

 

Buzz Smith posted this 02 February 2021

I downgraded the driver & app to an earlier release and everything seems to be working. I plan to eventually get a M1 Mac Mini, so I’m hopeful that transition goes smoothly.

Ranjith kumar posted this 02 February 2021

Hi Buzz,

Kindly let us know the driver version which you installed in your Mac OS 10.13.

Also reach us through support.promise.com fur quick response.

Thank you,

Regards,
Promise Team

Close