Promise Utility not working

  • 564 Views
  • Last Post 12 September 2019
Henry LANTERNE posted this 01 February 2019

Hello to all,

 

I'm working with Mojave and I had the same problem with High Sierra.

I have two Pegasus R4 connected to iMac with Thunderbolt connection. Since the migrations, my Pegasus are working fine and I'm able to work with them (backup, storage, etc...)

Unfortunately, my Promise Utilisy doesn't want to open. That means, I'm not able to access the interface to manage and I'm afraid if any issue occurs on a disk, I wont be able to change HD, or anything else.

I tried to uninstall my package and reinstall it after downloading R_Promise_Utility_400000009. (the latest version I found regarding my storage solution)

Is someone able to help?

 

Thank you for your help

Order By: Standard | Latest | Votes
arunkumar b posted this 04 February 2019

Hi Henry,

Please try download and install the latest version utility (4.02.0000.21)  to see if it works.

https://promise.com/DownloadFile.aspx?DownloadFileUID=6076

Regards

Arun

 

Henry LANTERNE posted this 04 February 2019

Hello Arun,

Thank you for the quick reply.

I removed as asked the old version of Promise Utility and re-installed the one you requested, but I have the same problem.

 

 

After installation, I have the bar menu at the top of my iMac, and it takes a long time when I try to click on the application buttons.

The application freezes after about one or two minutes and nothing starts.

 

I tried to see the preferences as described below and this menu starts.

 

The Pegasus devices are available and operationals thru the finder (backup, files access, etc...)

 

and the two Pegasus R4 connected as you can see in the system,

But unfortunately, the devices don't seem to be reachable by my system. I'm not able to shutdown properly the devices, unable to check the drive status or build or rebuilt anything without the interface.

 

If you have any idea, it will be very helpfull. I don't know how to fix this issue....

 

Thank you again for your support.

 

Best regards,

 

Henry

arunkumar b posted this 05 February 2019

Hi Henry,

Please open a support case at https://support.promise.com for further investigation.

Regards

Arun

Henry LANTERNE posted this 05 February 2019

Hello Arun,

 

Thanks' for reply.

I tried to connect to the provided link and impossible to access the site support.

The system indicated one of my credentials are incorrect, even I'm sure of them.

I requested a change password, with the dedicated function and received the email to change it.

Unfortunately, I'm not able to change it, the page stays as it, despite clicking the "Reset password" button.

Do you have any idea of this new problem?

I did the same thing with Safari, Firefox and Chrome with the same results.

 

 

Best regards,

Henry

Matt Palmer posted this 23 May 2019

I have this exact same problem with the disc utility not opening. I would appreciate an answer to this. I've already contacted support to no avail.

 

Matt

Henry LANTERNE posted this 29 May 2019

Hello Matt,

Since I opened the issue, some months ago, I never received any information or help to fix my problem and I'm always in the same state.

I was in contact with Promise technicians 1st level and they tried to help unsuccessfully. They had to escalate my problem to upper level, but I never had someone to fix it...:(

 

Rian Hughes posted this 31 May 2019

The utility doesn't work for me either. Just doesn't start. Pegasus drive only mounts intermittently.

  • Liked by
  • B Hud
Ratu Ratu posted this 20 June 2019

Hi, utility not working for me either. When I click on view and window they are greyed out.

I can see it is connected via Systems info but the drives don't mount on the desktop.

I have the latest version of utility ver 4.02.0000.21 and also the mac driver v6.2.9

Running on Mojave 10.14.5 on 2019 27" imac.

Any solutions please?

Thanks

Ratu

Attached Files

  • Liked by
  • B Hud
Chris Beck posted this 07 September 2019

Hi, utility not working for me either. When I click on view and window they are greyed out.

I can see it is connected via Systems info but the drives don't mount on the desktop.

I have the latest version of utility ver 4.02.0000.21 and also the mac driver v6.2.9

Running on Mojave 10.14.5 on 2019 27" imac.

Any solutions please?

Thanks

Ratu

 

Hey guys I am in the same boat here, and can't find a solution!  Please, any updates on this?  

Doug Dunlop posted this 12 September 2019

The utility doesn't work for me either. Just doesn't start. Pegasus drive only mounts intermittently.

 

I have the same problem in High Sierra with the Pegasus drive mounting most of the time, but then just stopping randomly and slowing down everything on the system when I try to use it. The promise utility will not start, so I don't know if it is my mac, the utility, the drive, or something else.

Close