Promise Utility just hangs in Mojave

  • 1.8K Views
  • Last Post 02 July 2019
Renny Willins posted this 07 November 2018

Hi. I have three Promises conected to an iMacPro and while volumes mount OK and are useable, the Promise Utility software just stays "connecting" and then times out.

  • Liked by
  • Dennis Watson
Order By: Standard | Latest | Votes
arunkumar b posted this 08 November 2018

Hi Renny,

We are sorry for the inconvenience caused to you. Could you please let us know the below details for further investigation.

1.Is this new setup?

2.Please let me know the Promise utility version installed in your computer

Could you follow the below steps and share us the result

-Uninstall the existing Promise utility 

-Restart the computer and Pegasus 

-Download and install the latest version utility to see if it works

Here is the link to download the latest version utility.

https://promise.com/DownloadFile.aspx?DownloadFileUID=4948

If still same issue,please open a support case in https://support.promise.com to assist you better.

Regards

Arun

Renny Willins posted this 08 November 2018

Thank you. I downloaded the latest version already and installed but no change. I will try the other steps... thanks.

Grant Klassen posted this 29 November 2018

I have a Pegasus2 R4 and the latest Promise Utility.

The first time I start the Utility, it looks like it's booting, but after about 30 seconds the application just quits. It usually starts the second time I try it.

Dennis Watson posted this 21 December 2018

Same issues.  

 

(1) Newly installed Mac Book Pro 2015 with Mojave Version 10.14.2

(2) Thunderbolt 2 direct connect

(3) Newly installed Pegasus2 R2+. 

(4) Downgraded Promise Utility to Release version : v3.20.0000.15 as upgrades o all newer versions are not stable.

 

 

Mick Kalber posted this 12 February 2019

I too am using Mojave Version 10.14.2, but am on a 2015 iMac 27-inch. Promise utility would not save a service report, crashing every time I tried. Tech support told me to download the new utility, which I did... but when I try to open it, title shows up at the top left of the screen with dropdown windows, but does not open on the desktop. No matter what I try, it will not open. Even trashed the app and reloaded it... same result. I've written problem on my open case, but have not heard back yet. Thought I'd ask the forum as well. Mahalo, 

Mick Kalber

Matt Palmer posted this 23 May 2019

Same issue as everyone else. The disc utility does not open.

Dan Donohue posted this 04 June 2019

They seem to have no interest in fixing it. I'm pretty much done with Promise products from now on.

P B posted this 05 June 2019

@ Dan Donohue

They seem to have no interest in fixing it. I'm pretty much done with Promise products from now on.

Have you tried executing a clean install of the Promise Utility?

Please review the following forum posting:

https://forum.promise.com/thread/promise-utility-window-won-t-open/

Dan Donohue posted this 19 June 2019

Have you tried executing a clean install of the Promise Utility?

Please review the following forum posting:

https://forum.promise.com/thread/promise-utility-window-won-t-open/

 I sure did. No effect. I've also tried all the versions that are downloadable and I opened a ticket about it. No resolution, then got to the point where you wanted remote access which I'm not allowed to provide. So here we are.

Daniel Larsson posted this 02 July 2019

I just ran into this issue since my Pegasus Promise 2 R6 does not mount on my Mac Pro 2013, nor on my Macbook Pro 15". Any progress?

Daniel Larsson posted this 02 July 2019

Alright, I solved the problem using the last link above by P B. The problem was that the kernal extensions were not loaded, don't know why. When I ran this command, I got nothing (supposed to find two extensions):

kextstat | grep 'com.promise.r2p.icon\|com.promise.driver.stex'

So I ran the two sudo kextload commands and rebooted. That did the trick.

 

Close