Promise Pegasus R6 unit won't turn on

  • Last Post 20 January 2023
Riot Nrrrd posted this 23 November 2020

I have already been in contact with Promise Technical Support and Promise Sales.  They say they can't help me because the Pegasus 1 units are EOL.

So I am asking the community: Has anyone ever had their Pegasus unit (of any generation) no longer turn on?  If so what did you do?

I had my R6 plugged into an APC Back-UPS unit.  One day the APC went belly up, it started screaming (making a high-pitched noise) and the front LCD said "Err02".  I couldn't get the noise to stop so I had to hold in the power button to force a power shutdown.

I bought a new APC unit to replace it, and when I plugged everything in my Mac mini and backup RAID unit came on just fine, but the Pegasus R6 is as dead as a doorknob.  Nothing I tried could make it turn back on.  (It had worked perfectly until the UPS died.)

Promise does not offer 0TB configurations to make upgrading units easy and their claim that you can buy empty units on their promiseshop Web site is non-existent.  I have no need to buy a new unit (and get 6 new disks I have absolutely no need/use for).  I just want to get this R6 unit fixed and of course they won't take it in since it is EOL'ed.

I can see posts on MacRumors.COM where people have changed out the fans (for quieter ones) in their Pegasus units.  So I know people have tinkered with them.

The original product manual mentions a "250W Flex-ATA Power with 80 Plus Bronze" PSU unit.  It looks like it's about a US $50 item.  But I need to know exactly what is the right item to try and buy a replacement PSU to fix it.

(Yes I know that Promise says "No user-servicable parts inside".  But the unit is out of warranty and EOL, so they won't take it back to fix it.  I figure that means I have every right to open it up since they won't fix it anymore.)

Order By: Standard | Latest | Votes
Art Bell posted this 20 January 2023

I dont think anyone is happy with PROMISE supprt anymore. Its like Mercedes not have any reapir shops. 

They 'repair' them by having oyu buy a new one. Great for their short term bottom line, Pretty disasterous for customer loyaly or customer recommendations. 

We have 12, i dont know what to buy now. I cant give any more money to a company that doesnt tand behind their products. 

  • Liked by
  • Gregory Pitzen
Riot Nrrrd posted this 25 December 2020

I am hoping that it is just an issue with the power supply unit and nothing else but I was wondering, is it possible to read the RAID drives using other equipment, like for example a server or a ReadyNAS?

Craig, I don't believe it's possible to get the data back by putting the drives back into any other enclosure than a Promise Pegasus unit.  Sorry.

Ultimately I was forced to buy another used Promise Pegasus R6 unit (with 6 x 1 TB drives that I couldn't use - I paid for them, but told the owner to E-waste them so the saved weight would lower the shipping cost).  I am back in action - at least, until the time the replacement Pegasus unit decides to croak (or the replacement UPS unit dies).

So I'm out $300+ and I'm not happy with Promise support.  Never buying another Promise unit again.  When it comes time to outgrow this R6 unit I will replace it with a NAS.  I don't want to be beholden to quickly-evolving technology (Thunderbolt 1, already extinct) or the host hardware/OS.  A NAS will give me that independence.

  • Liked by
  • Gregory Pitzen
Craig Crawford posted this 26 November 2020

I also have a first generation R6, but it won't turn on. The power button is orange so it is getting power, but it just won't power on. I have created a support case and I am been helped. I am hoping that it is just an issue with the power supply unit and nothing else but I was wondering, is it possible to read the RAID drives using other equipment, like for example a server or a Readynas? So removing the hard drives from the R6 and reading them with any other device. I have put TB's of data on the R6 and would like to get the data back.