Pegasus32 R6 Firmware

  • 195 Views
  • Last Post 29 March 2023
  • Topic Is Solved
Pieter Pretorius posted this 25 March 2023

When I use Promise Utility Pro it says that there is new firmware available. When I update, it gets stuck at about 27% and doesn't progress further. See screenshot. I'm using a Mac Studio running Ventura.

Order By: Standard | Latest | Votes
R P posted this 29 March 2023

Hi Pieter,

I have tested a Pegasus32 update with Ventura 3.3 on a MAC Studio and it ran without a problem.

What is the status of the Pegasus now?

I've had hang issues in the past due to using an incompatible Promise Utility and the Pegasus always came up after. Then I updated the Promise Utility and flashed it from the CLI.

The firmware is updating to this version...

Please try manually updating the firmware with the firmware file. The Pegasus Pro firmware update page has a manual tab on the left side, you can drag and drop the firmware file.

Pieter Pretorius posted this 29 March 2023

This worked perfectly thanks!!!

Close