Pegasus3 R6 not mounting any more.

  • Last Post 22 January 2019
Harold Herbert posted this 12 January 2019


I am using a 2016 Macbook Pro and the R6 24TB has been working fine with a direct thunderbolt 3 cable since first setting up. Today I rebooted to use a different network configuration for the mac and the R6 didn't show up. The lights are all blue but the Promise utility cant see it at all. The mac system report shows the thunderbolt port connected to the Pegasus. Disk utility can't see it. I found some good info on the forum but apart from trying different ports and rebooting most of the guidance needs the R6 to be shut down. I can't shut it down from the power button, it just stays blue even when held in 20". I read that unplugging the power is not safe but it seems like my only option in order to proceed with further diagnostics. I have unplugged the thunderbolt cable now and will leave the R6 for a few hours in case it is busy internally. If the power button still doesn't work is my only option to unplug the power? I want to be cautious as I have about 10TB of critical data on it that I need to access.


Thank you in advance for any help,

Kind regards,


Order By: Standard | Latest | Votes
Harold Herbert posted this 12 January 2019

I have opened a support case now but I am still trying to assess if I can safely unplug the machine. I tried connecting to a 2013 Mac Pro with T2-T3 convertor but the same issues occur except system report sees no thunderbolt connection.  A couple of months ago it worked fine on the mac pro.

Venkatachalam Settu posted this 12 January 2019

Hi Harlod,

We are waiting for your response on the case. Kinldly follow up the case.

Thank you.


Harold Herbert posted this 12 January 2019

Hi. Thank you for the fast response. I added my TV details to the support case.

Venkatachalam Settu posted this 12 January 2019

The issue has been resolved. Thank you.

Harold Herbert posted this 12 January 2019

Thank you! A very fast resolution...

Andrew Nickless posted this 21 January 2019

What was the solution?

Harold Herbert posted this 22 January 2019

The disks were OK but the software or firmware needed to be fixed. The technician from Promise teamviewed in and asked me to pull the plug on the R6 as it could not be shut down any other way. He then asked me to pull the disks out 2" and reconnect. He used terminal to do his magic and after 10 minutes I was working again. The whole episode took about 2 hours from the time I posted the first question and it was a weekend, so I was impressed and relieved!

  • Liked by
  • Kali Bateman