Pegasus3 R4 no longer functioning after OS upgrade Mac mini M1 Ventura 13.1

  • 512 Views
  • Last Post 15 April 2023
John Rosinski posted this 14 April 2023

I've reinstalled drivers and utility. See the following error in extensions

PromiseSTEX:

 

  Version: 6.2.16

  Last Modified: 12/9/20, 3:19 AM

  Bundle ID: com.promise.driver.stex

  Notarized: Yes

  Loaded: No

  Get Info String: Version: 6.2.16, Copyright (c) 2010-2021 Promise Technology, Inc.

  Obtained from: Identified Developer

  Kind: Universal

  Architectures: arm64e, x86_64

  64-Bit (Intel): Yes

  Location: /Library/Extensions/PromiseSTEX.kext

  Kext Version: 6.2.16

  Loadable: Yes

  Dependencies: Incomplete

  Dependency Errors:

  Dependency Resolution Failures:

  Indirect dependencies can't be resolved: com.apple.iokit.IOSCSIParallelFamily, com.apple.iokit.IOPCIFamily

  Signed by: Developer ID Application: Promise Technology Mobile Apps (268CCUR4WN), Developer ID Certification Authority, Apple Root CA

 

Order By: Standard | Latest | Votes
John Rosinski posted this 14 April 2023

R_MacDrv_V6.2.16.pkg
R_Promise_Utility_406000001

 

John Rosinski posted this 14 April 2023

Model Identifier: Macmini9,1

  Firmware Version: iBoot-8419.80.7

  Boot UUID: 5A67C926-1D8E-4FBB-B5C4-7C445B957ABE

  Boot Policy:  

    Secure Boot: Reduced Security

    System Integrity Protection: Enabled

    Signed System Volume: Enabled

    Kernel CTRR: Enabled

    Boot Arguments Filtering: Enabled

    Allow All Kernel Extensions: Yes

    User Approved Privileged MDM Operations: No

    DEP Approved Privileged MDM Operations: No

 

R P posted this 15 April 2023

Hi John,

To use a kernel driver in Ventura you need to change the boot policy, which you have done.

After that you need to go to Settings > Security and give the driver permission to run.

That is, first you need to give the driver permission to load, then it needs to be given permission to run.

If you desire a kernel driver you should use the latest version, 6.2.17-3, linked to below.

But Apple has deprecated kernel space divers (kext) and at some point they will stop working. It is recommended to use the user space driver (dext).  You can download the Pegasus DEXT driver here.

  • Liked by
  • Jim Feeley
Close