Pegasus2 RAID1 Logical Volume Won't Mount

  • 231 Views
  • Last Post 30 January 2022
Matt Warner posted this 29 January 2022

I have a Pegasus2 R4 with 4 drives. Two of them are passthrough and they work fine. The other two drives were setup a RAID1 (mirroring) using the Promise utility. The volume has stopped showing up. Even more strangely, with the two drives in the enclosure, the Promise utility hangs (beach ball of death). If I remove the drives, the utility is able to see the enclosure and the other two drives.

In the old days with SCSI drives, I recall seeing this type of thing when errors from a disk on a shared bus would cause chaos with all devices on the chain. These are SATA drives, however.

I've read through a number of posts. Here's what I've tried:

  • Made sure the latest firmware is installed on the array
  • Installed the Promise driver for macOS
  • Tried with just one of the two RAID1 drives installed (it's mirrored, so each drive has a complete copy)

The CLI shows the array (drives 1 and 4), even though it's marked 4 as dead.

cliib> phydrv

===============================================================================

PdId Model        Type      Capacity  Location      OpStatus  ConfigStatus     

===============================================================================

1    WDC WD30EFRX SATA HDD  3TB       Encl1 Slot1   OK        Array1 No.0      

2    ST31000528AS SATA HDD  1TB       Encl1 Slot2   OK        PassThru         

3    ST1000DM003- SATA HDD  1TB       Encl1 Slot3   OK        PassThru         

4    WDC WD30EFRX SATA HDD  3TB       Encl1 Slot4   Dead      Array1 No.1      

Also odd is that the volume appears to have mounted (the name doesn't normally have a "2" appended), though any attempts to access that volume just hang. It shows in the CLI but not on the desktop.

% df -h|grep RAID

 

/dev/disk7s2                          2.7Ti  2.6Ti  179Gi    94%    421796  4294545483    0%   /Volumes/RAID Drive 2

Info "diskutil info" also shows up

% diskutil info /dev/disk7

   Device Identifier:         disk7

   Device Node:               /dev/disk7

   Whole:                     Yes

   Part of Whole:             disk7

   Device / Media Name:       Pegasus2 R4

 

   Volume Name:               Not applicable (no file system)

   Mounted:                   Not applicable (no file system)

   File System:               None

 

 

   Hardware AES Support:      No

How do I get to the data?

 

Order By: Standard | Latest | Votes
Matt Warner posted this 29 January 2022

I even tried pulling one of the drives and connecting it to a SATA adapter, but the system doesn't seem to know how to mount the volume

/dev/disk4 (external, physical):

   #:                       TYPE NAME                    SIZE       IDENTIFIER

   0:     FDisk_partition_scheme                        *3.0 TB     disk4

   1:                       0xEE ⁨⁩                        375.0 GB   disk4s1

                    (free space)                         426.6 GB   -

 

Matt Warner posted this 29 January 2022

This command gives partial info but then hangs:

% diskutil info /dev/disk7s2

   Device Identifier:         disk7s2

   Device Node:               /dev/disk7s2

   Whole:                     No

   Part of Whole:             disk7

 

   Volume Name:               RAID Drive

   Mounted:                   Yes

   Mount Point:               /Volumes/RAID Drive 2

 

   Partition Type:            Apple_HFS

   File System Personality:   Journaled HFS+

   Type (Bundle):             hfs

   Name (User Visible):       Mac OS Extended (Journaled)

   Journal:                   Journal size 229376 KB at offset 0x2bac000

   Owners:                    Disabled

 

diskutil: interrupted

 

Gautham Sakthi posted this 30 January 2022

Hello Matt,

PD 4 is marked as dead and we need the subsystem report to check further about the failure.

Kindly go to support.promise.com to create a websupport ticket and attach the service report.

Steps to save the subsystem report :
 
1) Open Promise Utility.
2) Click subsystem information icon on the top of the window.
3) Click the lock symbol on the left bottom corner of the screen to unlock the utility.
4) Click on save service report button to save the subsystem report

Close