Pegasus2 R8 not working on Windows 10

  • 859 Views
  • Last Post 23 December 2020
Tuomas Hakala posted this 28 November 2020

When I connect Pegasus2 to my windows computer it shows on Thunderbolt Control Center as Pegasus2-R, but the drive doesn't pop on the file system, nor Promise Utility.

I have Gigabyte B550 Vision D motherboard that has two type-C ports with Titan Ridge controller. In between I have Apple's TB3 to TB2 adapter. I've tried the latest driver 6.2.0.11 from Pegasus2 downloads, I also tried the one from Pegasus3 that has WHQL in the name but no success. In addition, I also tried older 5 series driver but that didn't work either, the system saw it as driverless. On a side note, the driver 6.2.0.11 from Pegasus2 downloads is the one I also used on my iMac Pro's Windows bootcamp and there it works flawlessly just like it does on OSX. It doesn't work on this new PC though. In Windows I have Paragon's HFS so this is not a format issue. My other Mac drives work just fine on the PC.

If I reboot the new PC with Pegasus connected, the driver in device manager will be offline like it is for any unplugged drive, however, Pegasus2-R still shows connected on Thunderbolt control center. If I turn on/off the Pegasus, or unplug/plug the cable while Windows is booted, it shows up on device manager too but goes to the state with warning triangle on it and when opened it says "This device cannot find enough resources that it can use (Code 12)". Further more I started to get the bluescreen of death on Windows refering to the driver "stexstpt.sys". This also never happened on the iMac Pro booted to Windows. So the this file seems to be where it all breaks down.

When my PC boots up again my USB keyboard doesn't react well on keys, or might type dozens of letter per single keypress. Restorting the computer to the state before Pegasus2 installation seemed to have solved these issues. I didn't try Pegasus2 with my keyboard disconnected and their Bus Numbers are different. Keybord shows on 2 and 3 (I don't know why there are two) while Pegasus had Bus 9. I'm not sure if any other device could be in conflict with it.

Anyways I need to get this system to work with my Windows PC and from the bootcamp Windows I know there shouldn't be any reasons why it doesn't work. Obviously I also installed the motherboards Thunderbolt driver. Everything was the newest. Including Pegasus2 firmware.

My PC specs apart from the motherboard mentioned before are AMD 5950x, Colorful 3090, 64GB RAM, 2TB Aorus Gen4 NVMe. In addition I have USB 3.1 hub connected to one of the boards USB32 ports and I have USB keyboard and mouse on USB2 ports. 

Attached Files

Order By: Standard | Latest | Votes
R P posted this 01 December 2020

Hi Tuomas,

it shows up on device manager too but goes to the state with warning triangle on it and when opened it says "This device cannot find enough resources that it can use (Code 12)".

This may be a limitation of your motherboard.

From the product manual, page 13.

  • https://download.gigabyte.com/FileList/Manual/mb_manual_b550-vision-d_1002_e.pdf
  • Thunderbolt™ 3 Connector (USB Type-C™ Port, with USB 3.2 Gen2 support) The connector supports standard DisplayPort and Thunderbolt™ video outputs. You can connect a standard DisplayPort/Thunderbolt™ monitor to this connector with an adapter. The Thunderbolt™ connector can daisy chain up to six Thunderbolt™ devices. Because of the limited I/O resources of the PC architecture, the number of Thunderbolt™ devices that can be used is dependent on the number of the PCI Express devices being installed. You can adjust the Thunderbolt™ settings under Settings\Thunderbolt Configuration in  BIOSSetup.

Also I'm confused. The ports are TB3 compatible, but you seem to be going through a USB 3.1 switch.

  • In between I have Apple's TB3 to TB2 adapter.
  • In addition I have USB 3.1 hub connected to one of the boards USB32 ports

The Pegasus 2 requires a thunderbolt connection and won't work with USB like the Pegasus32 will.

Also, I was doing some Windows testing last week, and while the Pegasus32 and Pegasus 3 worked well with a Windows 10 Thunderbolt 3 machine, when I used the Apple TB3 to TB2 adapter, I was not able to see either the Pegasus 2 or Pegasus 1. Some googling suggests the problem may be that Apple's TB2 to TB3 adapter may not be compatible with many Windows motherboards. They suggest using a different brand. Unfortunatly I don't have any other adapters to test with. But it might help to do the following google search...

  • "does the Apple thunderbolt 3 to thunderbolt 2 adapter work with Windows 10"

Note, this might help, but not while the driver can't load due to resource limitations. That needs to be solved first.

Tuomas Hakala posted this 01 December 2020

Hello R P

Thank you for getting back to me. As you can see on the screenshot I posted the Pegasus2 also shows on the Thunderbolt Control Center correctly. This was not motherboard not supporting Thunderbolt issue. Besides the GPU is standalone, and the monitors connect there. These two ports on motherboard have Titanridge controller. Only thing adjustable in BIOS is if TB ports are protected or unprotected, require approval on connection or such.

I'm not going through USB switch. Pegasus is in the Thunderbolt port. In ADDITION I have keyboard and mice connected, and a USB hub, to which I now actually connected that keyboard, mice and additionally a wacom drawing tablet. I'm simply put mentioning to you all the devices since system seemed to think something was overlapping, because these mysterious error messages, and strange behaviour after driver installation seemed to hint that way

I used Apple's adapter on iMac Pro when it was booted to Windows and it worked, so windows definitely supports it.

Since the computer was unstable, keyboard playing its tricks, and blue screens of death hitting me from the Pegasus driver mentioned as a culprit, I did system restore back to before all this started. Next day I still decided to try it once more as I also had TB2 WD drive laying around, I couldn't get it to show either as an extenal disk and the Thunderbolt Control Centre was now gone (apparently it is installed by the Promise Utility) so I also had no method to test if it was showing.

So I went again and installed Pegasus utility from Pegasus3 (THREE) downloads and the Thunderbolt Center was back. I was unable to make the WD drive work while it too showed on the utility with correct names, but WD never promises any support on windows for this small RAID1 drive in form of drivers, and I'm guessing if it wasn't RAID, it would have worked). Having gone this far again I thought to install the Pegasus3 WHQL driver again (This is not in Pegasus2 downloads section). Try it fresh. I had tried it day before but that was simply overwritten on the non-WHQL, one which is available from Pegasus2 downloads. Suddenly after reboot and every reboot ever since the Pegasus2 is now showing on my windows and operating correctly.

This time it seems to be on different BUS and so is my Keyboard and mice since I moved them from backpanel USB2 ports to the USB hub connected to backpanel USB32. I don't know if these make any difference but they may, since I had the keyboard not responding and typing itself before while Pegasus driver was installed. Only problem seems to be now that when I switch the keyboard to Bluetooth mode it doesn't discover itself on reboot and have to do that manually or just use the cable. But it no longer has unresponsive keypresses or doesn't type dozens of character on every press.

CONCLUSION

Currently Gigabyte Vision D B550 Thunderbolt 3 connectors - Apple TB3 to TB2 adapter - Pegasus2 work together. It was extremely frustrating to get it to work and I think main culprit is the driver you offer at Pegasus2 downloads. You should simply remove all those and give people what you offer at Pegasus3 downloads. Or define some way to test for whom which driver is the best. We still need to remember that on iMac Pro booted to windows those original Pegasus2 downloaded drivers and apps worked well. Having used original Pegasus since it was released I love the reliability of your products. I hope you can keep these old units compatible with non-Macs also since apart from limited connectivity, they are just as good as the new ones and higher bandwidths on newer units don't really make the drives any faster. It is extremely hard to justify selling away something that works. There are not that many Thunderbolt Motherboards available. For my 5950x Ryzen build I really had only this Vision D and twice as expensive X570 Creator available. There is one ITX board for AMD (forgot what it was called since ITX doesn't have enough other expansion options for me) with one single Thunderbolt connnector available. I'm sure on Intel side you can find more, but I still hope that in the name of keeping your products reliable and protecting the longevity of the customer's investment, that you look into more motherboards and tweak out the firmware quirks for you longterm customers

Thing that I really would like to see on Pegasus is added inputs, ability to connect two computers at the same time. For example two type-c inputs, regular (old style) USB, and a network connection.

R P posted this 01 December 2020

Hi Tuomas,

Thing that I really would like to see on Pegasus is added inputs, ability to connect two computers at the same time. For example two type-c inputs, regular (old style) USB, and a network connection.

This will not be possible for several reasons. First, only one driver can connect to a Pegasus at a time. The second TB port is for passthru to connect other TB devices. And also, HFS+ is not a clustered filesystem, if more than one computer mounts it at a time, then very bad things will happen. Neither NTFS, APFS or Windows ReFS are clustered, they can only be used by one computer at a time. If shared storage is needed the current solutions are to get a NAS or to reshare the Pegasus from macOS or Windows.

Tuomas Hakala posted this 06 December 2020

It is broken again. After reorganizing my table and replugging USB cables, the Pegasus went offline back to the Error 12 mode indicating it doesn't have enough resources and that I should disable other devices. But even if I unplug every usb device, the Pegasus will not load. It shows on the TB Control Center as usual. It was stable until this happened, although between I only used the USB ports on the external HUB for other devices vs the mobo's ports. Seems like the fact that I plugged something to the mobo messed up the TB again. Even if I put the cables back to way they were, it didn't help. Doing system restore in that state to the state where Pegasus was working didn't bring it back up either.

I did some more digging over this error and I can't find anything directly related to Pegasus, or HDDs or RAIDs but people with eGPUs run through TB have encountered similar errors. Suggested solutions was adding HackFlags to registry, but it didn't work for me, not sure if it even does anything in my situation, but nevertheless tried it.

Other solution was some complicated DSDT modifying process to turn it from 32bit mode to 36bit mode to enable some Large Memory state but this seemed way too complicated with having to recompile some hand modified system files. This seemed to have something to do with the bus registry having too little memory available for complicated TB devices.

I also found something about enabling "above 4G decoding" on BIOS which seems to relate to previous point somehow but being an independent solution. So I enabled that and I raised the "Memory per Port" and "Prefetch Memory" on the same BIOS menu as the function hint says having these too low may cause devices not to work. I booted and to my amazement Pegasus was online again. I got excited, moved my keyboard, mouse back to the mobo's USBs, I plugged in normal USB hard drive there, and Wacom tablet, and everything stayed online same time. For a moment I thought this was it. I rebooted and everything was there, then Pegasus dropped and popped up automatically like it had be reconnected. I rebooted again and everything was gone. Removing all the USB devices and rebooting didn't bring the Pegasus back, neither did system restore to when it was online. The driver keeps going to the Error 12 mode every time I install it. Also at times it messes up the computer totally, again makes my keyboard go crazy or cause bluescreen of death crashes from the driver, even when Pegasus isn't connected. 

Among the eGPU hackers people were reporting that earlier version of Windows worked better and supposedly Microsoft changed something on the PCI.sys file. Editing that file, replacing it with some earlier version of Windows was suggested as one solution, although later someone added that Microsoft seemed to have removed ability to do that causing the PCI.sys the reset automatically. So the only possible solution, if that PCI.sys file would be the culprit, would be to install some year old version of Windows and disable updates. Later someone else reported though that at some newer version (which is older than what I have) Microsoft would have fixed what ever was problem with that file regarding to the TB.

I can't imagine what I should do now to fix this. When this conflict happens it is also impossible to see the from the resources tab what it is conflicting with since that tab also just prints the same error message rather than the usual menu.

Tuomas Hakala posted this 11 December 2020

I was able to source Startech TB3 - TB2 converter but the result is the same. I'm still getting same errors with resources and same crashes caused by the Pegasus driver. When Windows installs it automatically, it actually finds newer version of the driver .16 vs .11 on your package. Neither works.

Tuomas Hakala posted this 23 December 2020

I have another update with the issue still existing. After fresh install of Windows, I got it workingwith cold-swapping, as in attach the while computer power off, then power on pegasus, power on computer. This was with few USBs connected to the backpanel also. Then I added some more USB devices, filled all the ports and everything was working. I rebooted the computer and Pegasus is again in not enough resources state. I power off, power on computer with same results. I plugged off other USB devices until I had only keyboard and mouse left and power off power on computer and Pegasus was back. Then I could add some devices again using power off power on between, as in I can't even hot-swap USB devices while computer is on, but changing USB ports while computer is off, then power on got the devices online. I only started to run to problems when all of the ports where occupied. It seemed stable like this but day later I found my computer had rebooted to that menu where something is wrong with Windows that can't be started, it offers you to fix problems that prevent computer from booting and that didn't work, it couldn't fix it. I had run into this problem also on earlier runs before fresh install so I went to do system restore but now computer said there are no restore points available, although I had made many after reinstalling Windows while testing Pegasus out, and I had actually done few restores before, but they were totally gone. I had to boot to command promt and fix stuff manually... Looking at the crash and the history, it looks like the Pegasus driver somehow had managed to crash computer so badly that the system drive's NTFS partion had corrupted itself. That was also the reason why regular fixing or restore didn't work anymore. So not only is it hard to make it work with Windows but it can lead to serious complications. It is clearly not an adapter issue as I got Lacie's rugged drive that has TB2 connector and that works fine when plugged to the computer. It can be hot-swapped too and it doesn't cause any instability while being plugged. The problem with Pegasus seem to be caused by the "stexstpt.sys". Again on iMac Pro running windows these issues do not happen.

Close