Pegasus2 R4 on Big Sur

  • Last Post 08 March 2021
Ho Seong Hwang posted this 24 February 2021


I was trying to mount my Pegasus2 R4 with Big Sur ver. 11.2.1 on iMac, but failed.

I installed the driver from the promise webpage(6.2.16) following the instruction, but could not see the disks. I then tried to manually load it as seen in following screen capture, but could not any change (still not loaded).

* screen capture:

Any suggestion please!!

Ho Seong

Order By: Standard | Latest | Votes
Ranjith kumar posted this 25 February 2021

Hi Ho Seong,

You have to verify the Boot Policy where Kernel extensions need  to be allow. Kindly verify the pdf file in driver folder where you find instruction  how to allow Kernel extensions, you can refer below link to download driver and pdf file:

Thank you,


Promise Team



Ho Seong Hwang posted this 28 February 2021

Hi Ranjith,

Thanks for your suggestion. Actually, I did following that instruction, but could not succeed.

In the end, I've managed to mount it after disabling System Integrity Protection (i.e. csrutil disable at the booting terminal)

Ho Seong

Frank Heijmans posted this 08 March 2021

I have the same problem. The 6.2.16 driver is not loaded.  Manual loading didn't do anything.

The instructions in the pdf aren't correct (maybe only for the M1). There is no Reduced Security Option in the Startup Security Utility nor any mention of kernel extensions.

For me csrutil disable didn't do anything. Also resetting smc an pram and nvram didn't do anything. I'm getting desperate. I need my data.