Pegasus2 R4 - Not working on Mac Pro 5,1 with Titan Thunderbolt card

  • 171 Views
  • Last Post 25 February 2021
Dominic James posted this 03 December 2020

Hi guy's,

Hope someone can help. I have a Pegasus2 R4 which works a treat on my Macbook Pro (late 2013) running Catalina and the PowerSTEX extension is version 6.2.13 The same drive connected to my Mac Pro 5,1 (2011) with the Thunderbolt Titan Ridge card added (every other Thunderbolt device I add works) and when the RAID is connected it has a kernal panic crash on start up. If I connect after a soft restart it is listed in the system report as connected and loaded, the PowerSTEX driver on the Mac Pro is version 6.2.9 not the same as the Macbook Pro. If I remove this driver the Mac Pro starts up no crash, the drive is listed but doesn't mount. Also the Promise Utiliy does have a window. Is there a way of getting the PowerSTEX 6.2.13 driver to see if I install it if it loads the drive? Can't seem to understand the versioning numbers listed in the software download page, it only offers the 6.2.9 version. Not sure how the 6.2.13 version got on my Macbook Pro.

Thanks

Order By: Standard | Latest | Votes
R P posted this 04 December 2020

Hi Dominic,

The 6.2.13 driver is available for download in the Pegasus32 section. Here is the link.

https://www.promise.com/DownloadFile.aspx?DownloadFileUID=6224

The STEX driver is inbox in macOS (exept for M1) and was probably updated to 6.2.13 last time you did macOS updates.

Roberto Vigani posted this 25 February 2021

Have you managed to solve this issue? I have a Mac Pro 5.1 and a Pegasus2 R4. I would like to understand how can I connect the MP 5.1 to the Pegasus.

Close