Pegasus2 R4 not recognized by Mac OS Big Sur BETA 6

  • 155 Views
  • Last Post 4 days ago
Gerald Skrocki posted this 3 weeks ago

Installed Mac OS Big Sur beta 6 (20A5364e) overnight and now I can't access my Pegasus2 R4 drive. It show up in system information but not on the desktop or in Disk Utility. It worked in the previous beta. I tried rebooting unpugging, using a different Thunderbolt port, reinstalling Promise Utility (which still does not work) all to no avail. 

 

  • Liked by
  • hyunsoo kim
Order By: Standard | Latest | Votes
Ranjith kumar posted this 3 weeks ago

Hi Gerald,

Could you check with conneccting Pegasus 2 R4 with Mac where Mac OS is Catalina or lower version.
Since we don't have any update on BigSur Beta 6, we can't sure that Pegasus2 work with it or not.

Please reach us through support.promise.com if you still have an issue.

Regards,

Promise Team

Gerald Skrocki posted this 3 weeks ago

No, I can't and your team should be aware of this problem. It is mentioned in several different places in this forum. It does appear to be a driver issue since a temporary solution mentioned in this forum, is to reinstall the latest (2017) Pegasus driver from your site and to force quit the installer before it tries to reboot your computer. This allows access to the drive and the Promise Utility software but it is only a temp solution because rebooting the computer causes the problem to repeat.

Please provide a new driver ASAP, your team has access to the beta software.

Simon Bailey posted this 3 weeks ago

I also have this problem.  The drive was working on the previous Beta & still works on Catalina, but not on Big Sur 20A5364e. I will report this to Apple via feedback later today in case they have done something to break the drivers. (It has happened before!). In addition the Promise utility does not work.  No windows are displayed, the icon just sits in the dock.

 

  • Liked by
  • hyunsoo kim
Eduardo Araquel posted this 2 weeks ago

Big Sur Beta 7 has fixed this problem!

Gerald Skrocki posted this 4 days ago

Big Sur Beta 7 has fixed this problem!

I just installed this beta 11.0 Beta (20A5374i) and the problem still persists.

 

Close