Pegasus2 R4 not recognized by Mac OS Big Sur BETA 6

  • Last Post 10 May 2021
Gerald Skrocki posted this 09 September 2020

Installed Mac OS Big Sur beta 6 (20A5364e) overnight and now I can't access my Pegasus2 R4 drive. It show up in system information but not on the desktop or in Disk Utility. It worked in the previous beta. I tried rebooting unpugging, using a different Thunderbolt port, reinstalling Promise Utility (which still does not work) all to no avail. 


  • Liked by
  • hyunsoo kim
Order By: Standard | Latest | Votes
Ranjith kumar posted this 09 September 2020

Hi Gerald,

Could you check with conneccting Pegasus 2 R4 with Mac where Mac OS is Catalina or lower version.
Since we don't have any update on BigSur Beta 6, we can't sure that Pegasus2 work with it or not.

Please reach us through if you still have an issue.


Promise Team

Gerald Skrocki posted this 09 September 2020

No, I can't and your team should be aware of this problem. It is mentioned in several different places in this forum. It does appear to be a driver issue since a temporary solution mentioned in this forum, is to reinstall the latest (2017) Pegasus driver from your site and to force quit the installer before it tries to reboot your computer. This allows access to the drive and the Promise Utility software but it is only a temp solution because rebooting the computer causes the problem to repeat.

Please provide a new driver ASAP, your team has access to the beta software.

  • Liked by
  • Loren Haynes
Simon Bailey posted this 11 September 2020

I also have this problem.  The drive was working on the previous Beta & still works on Catalina, but not on Big Sur 20A5364e. I will report this to Apple via feedback later today in case they have done something to break the drivers. (It has happened before!). In addition the Promise utility does not work.  No windows are displayed, the icon just sits in the dock.


  • Liked by
  • hyunsoo kim
Eduardo Araquel posted this 19 September 2020

Big Sur Beta 7 has fixed this problem!

Gerald Skrocki posted this 23 September 2020

Big Sur Beta 7 has fixed this problem!

I just installed this beta 11.0 Beta (20A5374i) and the problem still persists.


  • Liked by
  • Leo Kuhn
Leo Kuhn posted this 06 October 2020

It is still broken in beta 9.

Gerald Skrocki posted this 06 October 2020

Yes, unfortunately. Promise hasn't updated their Mac driver since 2017. It's time!

Andy Epprecht posted this 07 October 2020

Same problem here! In beta 9 (20A5384c) I do not have access to my Pegasus2 R4!

My Pegasus2 R2+ that is chained after the R4 is seen and works well but not my R4.

Please fix this for your loyal users.

(And finally if Promise would sell 'diskless' Pegasus32 devices one could consider upgrading). 

benjamin henon posted this 08 October 2020

SAME PROBLEM !!  help :/ 

Filip Remplakowski posted this 14 October 2020

I seem to be having the same problem... it was working for a bit then had issues and I came on here and read about the driver install trick which remedied the problem for an evening and then down to an hour then lower for a few days but then that stopped working. Have connected it to another Mac (also updated that to Big Sur as living dangerously in lockdown) and also not mounting my Time Machine and media drives but it does recognise that it's connected.

Gerald Skrocki posted this 15 October 2020

Good news! Mac OS 11.0 Beta (20A5395g) fixed the driver loading problem on my late 2013 Mac Pro. Everything is now working as expected.

Filip Remplakowski posted this 16 October 2020

Hmmm, updated mine to the same but it still doesn't mount. Hopefully, it'll work when Big Sur GM is released, if not I'm assuming I can put the drives in a caddy and access the data like a normal hard drive. I was thinking of eventually shifting it all to an unraid server (more of a cost and support thing as I saw the first pegasus are not being supported) at some point in the future. depends on what Apple does with the Mac mini

Gerald Skrocki posted this 16 October 2020

I don't know why Big Sur Beta 10 didn't fix the problem on your computer. It did on my late 2013 MacPro and the Pegasus2 R4.

Filip Remplakowski posted this 16 October 2020

Nevermind it works (for now 😅). It's a good idea to restart the Pegasus drive once you do the software update.

Brian Duncombe posted this 07 May 2021

I am on MacOS 11.3.1 but my troubles have been since the start of Big Sur

After booting the system, my Pegasus2 R4 connected via thunderbolt on a MacbookPro 15" 2017 works fine.

Within an hour or so of inactivity, the connection to the drive drops.  When I am away from the system, Time Machine runs hourly and sometimes manages to revive the connection.  During the night, I get a warning every hour telling me that I should eject the drive before disconnecting and the Time Machine process fails.  In the morning, about the only way to get the drive back is to physically disconnect, wait a few minutes, and then plub back in, although that often doesn't work.

R P posted this 10 May 2021

Hi All,

The Pegasus driver has been continuously updated since the Pegasus first came out. The Pegasus driver is normally backwards compatible (except for a few + models). To use the latest driver download the latest Pegasus 32 driver. I have even tested it with a Pegasus 1 R4. It is also M1 compatible.