Pegasus2 R4 Drive not working with MacBook M1 Pro

  • 184 Views
  • Last Post 2 weeks ago
David Veitch posted this 4 weeks ago

Attempting to load my Pegasus2 R4 Raid drive on my Macbook M1 Pro Laptop (new 2021 model). Although the Raid springs to life nothing shows up on the computer. I'm obv having to connect using a thunderbolt 2 to USB C adapter. Note that I have also installed the Promise Utility App, although this shouldn't make much of a difference.

 

The drive worked flawlessly with my iMac 2015 model running Big Sur. What's going on with running these on the new Macbooks? 

Order By: Standard | Latest | Votes
Jason Woodcock posted this 4 weeks ago

Same here following

  • Liked by
  • Deborah Freerksen
Paul Avampato posted this 4 weeks ago

Same here also following for any help

  • Liked by
  • Deborah Freerksen
坤 钟 posted this 3 weeks ago

Today I received the M1 MAX computer, first install the driver and promise utility, use Thunderbolt 3 to Thunderbolt 2 cable, connect the computer and R8 R4, it can be used normally.

Margaux Yiu posted this 3 weeks ago

I was having a lot of problems and did the following:

  • update the driver (follow manky procedure to bypass Mac security and allow access to stuff)
  • update the utility
  • update the firmware
  • update the OS (still on Big Sur)

Raid appears fine, but…when computer goes to sleep, Raid gets improperly ejected and I get error message. Now looking for how to make that stop.

Paul Avampato posted this 2 weeks ago

Recevied support from Promise on how to properly install the driver.  Follow the instructions in the included PDF to check or change your Mac security features first.  Once I changed the security settings and installed the driver the drive showed right up and is working well. 

Close