Pegasus2 R4 crashing M1 MacBook Pro max

  • 994 Views
  • Last Post 13 October 2023
Carl Henry posted this 21 September 2023

I have tried to follow the steps presented in the instructions but I can not clear this up. System crashes as connection with raid is created. I have seen several other posts and problem will be corrected with new release of promise utility.  Has it been released?

Order By: Standard | Latest | Votes
R P posted this 26 September 2023

Hi Carl,

It may be a driver issue.

First, you should install the correct driver. This is the user space driver and a reboot is not usually needed after it is installed.

After the install you'll have to allow the driver to run, the installer prompts you.

I'm not aware of any crash issues caused by Pegasus2 firmware, but if it is downrev you may see some disconnect issues with an M1 Mac. This KB goes over the details.

Please note that only the firmware from the Pegasus2 downloads should used, the other files are not forward compatible with the M1 macOS. The drivers and Promise Utility should be downloaded from the Pegasus32 downloads. These are compatible with the M1 macOS and backwards compatible with the Pegasus2.

Carl Henry posted this 13 October 2023

Promise Admin,

Thank your response.  I followed your detailed insturctions and the problem has been solved!

In a time when a lot of companies want to drop all support for older but functional devices, thank you  for your support of retired product lines that continue to provide excellent service for a lot of people!!!

Carl Henry

Close