Pegasus2 R4 boots, then red light and shuts down

  • Last Post 17 April 2020
Ray Argall posted this 15 April 2020

I've just received a Pegasus2 R4, which was slightly damaged in transit. All the drives and drive casings seem okay, there is a crack in the top RHS but otherwise the main casing and contents seem okay no apparent damage. When I boot up the R4, it fires up, all the blue lights work, then power light goes amber, then red and it immediately shuts down, which I presume is a safety mechanism. This happens whether there are drives in the bays or not. I have a Pegasus2 R8 which is fabulous, and was adding to the chain. This is not a new item, hence posting to see if anyone knows of this behaviour and if it's a sign the R4 is completely dead or can be retreived?

Any leads would be greatly appreciated!




Order By: Standard | Latest | Votes
Raghuraman Kannan posted this 17 April 2020

Hi Ray,

Pegasus 2 units will not stay ON if the Thunderbolt connections are not established. Please make sure that the Thunderbolt connections are proper and try with a new Thunderbolt cable.  

Thanks !

Ray Argall posted this 17 April 2020

Hi Raghuraman,

Thanks for the response. You're right! TB connections can be tricky, I tried the other port and it worked okay. I was then able to get the Promise Utility to recognise the unit, which it said was okay, however the unit was only recognising one of the four drives. I tried with another set of drives I know to be good and the unit still only recognised the drive in Bay one. So I was able to get the unit to power up with blue light when no drives were in. I have an older R4 unti that has a problem where drive bay three is reading as a failed disk - after this happened with three different drives - always in bay three, I concluded it was the unit, hence looking for a replacement. The P2 R8 is performing very well. With this unit I will return to the seller as it was clearly damaged in transit.