Pegasus2 hard crashes Mac Studio M1Max running Ventura 13.1

  • 110 Views
  • Last Post 3 weeks ago
Martin Curtis posted this 3 weeks ago

Hi,

I have 2013 iMac running Mojave (10.14.6) and a Pegasus2 R6, and a Mac Studio M1Max running Ventura 13.1 with a Pegasus32 R6.

The Pegasus32 is up and running just fine using the latest Mac Driver 6.2.16. If I plug the Pegasus2 into the Mac Studio using Apple's Thunderbolt3 to Thunderbolt2 adapter, the Pegasus 2 momentarily mounts and then the Mac Studio crashes and reboots. I have plugged the R2 into the Mac Studio directly, into the R32 and even into a Mac Thunderbolt Display that is daisy chained to the R32.

 

Any advice?

Order By: Standard | Latest | Votes
R P posted this 3 weeks ago

Hi Martin,

Please load the lates Pegasus 32 M1 user space driver. It is backwards compatible with the Pegasus 2.

Please note that the latest Pegasus 2 firmware will be required for use with an M1 MAC or there will be disconnect issues.

This is Service Release 3.3.4, firmware version 5.04.0000.64.

It would be best to update the Pegasus 2 firmware from the 2013 iMAC if it is necessary.

  • Liked by
  • Martin Curtis
  • Charles Allen
Martin Curtis posted this 3 weeks ago

I just tried to download the firmware and the image won't mount. It seems to be corrupted. I tried two different computers and both gave the same result.

One download was via the Promise download centre, and another was directly using the link you included.

Thanks for your help so far, hopefully you can find a non-corrupted file for me :-) 

R P posted this 3 weeks ago

Hi Martin,

Ah yes, this is an issue that will be fixed in the next release of the Promise Utility.

Till then, the workaround is to use a slightly older utility. Version 4.06.0000.01 should work.

Martin Curtis posted this 3 weeks ago

 Now the Pegasus2 doesn't mount on anything.

R P posted this 3 weeks ago

Hi Martin,

Firmware updates do not affect data on disk.

Is the Pegasus powering on with all blue lights?

If so please check the system profiler and see if the Pegasus shows up in the Thunderbolt devices and check that a volume is seen in disk utility.

Close