Pegasus2 Compatiblility with macOS 14 Sonoma

  • 2.6K Views
  • Last Post 08 March 2024
Mark Dorset posted this 27 September 2023

Has the Pegasus2 R4 (or other similar models) been tested againt the new macOS 14 Sonoma that was released today? I do not want to upgrade my M1 Mac Mini host before knowing it will continue to function with the R4.

  • Liked by
  • Cory Dorschel
  • Igor Schlumberger
Order By: Standard | Latest | Votes
Cory Dorschel posted this 28 September 2023

Yup. Have a Pegasus2 R4 RAID acting as storage for one of my Mac Studio Ultra's. Been running Sonoma Beta's as a developer since June. As long as you have the same drivers for M series Mac's running on Ventura, upgrading should be fine. 

Palle Jensen posted this 06 October 2023

I have a Mac Studiso M1 Max and a Pagasus R3-4 and a Pegasus R2-6 connected. The drives performs fine (and show up in Finder), also after upgrading to Sonoma 14-0, but the Promise utility (4.06) does never really start up when selected !!!

When I select check for updates I am advised I have the newest version!!! But it does NOT work. When will there be a fix?

Just to make sure, I connected the Pegasus to my older macbook pro, running Ventura and then the utility (4.06) would work.

GreyT

R P posted this 06 October 2023

Hi Palle,

While we have not seen any Sonoma compatibility issues with the Pegaus, we have seen the update itself break things. In one case the links Premiere keeps to files on the storage were broken, regenerating the links fixed that. This customer had a project due and was very upset.

In the case of the driver, we have seen several cases where the update a seemed to disable the driver somehow. The solution is to reinstall the driver.

Before updating to Sonoma, it seems a good idea to do so when there is no work in progress or pending and there is time to resolve any issues discovered.

iOS 17 is out, but I have not updated yet. If you read the news they have already fixed several major issues, I'll wait a bit longer before updating though.

Palle Jensen posted this 10 October 2023

Thanks RP

but it was the utility that seems not to make the final connection, the window with the rotating pattern will show the name of the Pegasus units it looks for... but alas nothing happens.

clicking on the "lock" position makes it visible... so I gather it is something in the grafpics of that window that sort of covers the true info???

The drives as such works perfect, and can be seen in Finder

R P posted this 10 October 2023

Hi Palle,

Wait, did they replace the beach ball in Sonoma with that?

If the volume is mounting then the driver is not the problem.

Some forum posters have seen issues of this type after updating and report that after rebooting things worked as they should.

Another possibility is that the Promise Utility was affected by the update to Sonoma. Please uninstall the Promise Utility and install this version.

Palle Jensen posted this 13 October 2023

Hello again.

I unimstalled utility, and downloaded the one from the link (it was SAME version), and nothing has improved. The Pegasus works excellent with the data as seen in Finder.

the thing is that the utility recognizes the 2 pegasus units correctly, by their description and as I mentioned when I click the position for the Lock there is a sound and the loch is shown as open... but the screen where all the settings are, is never shown. So I gather that is some quirk in the way the side is (not) presentet/shown.

My only option for checking  the status/ changing parameters is to disconnect the TB cable from my Mac Studio and connect the TB cable to my Macbook Pro, which runs Ventura.

Just for fun I installed the PRO Utility and this works fine... like this

So I gather there is something you need to fix in the normal utility

GreyT

Palle Jensen posted this 20 October 2023

I am waiting for response to this question!!! When wil the Promise Utility (standard version) be updated ???

This passivity is not what I ecpect from Promise...

GreyT

Palle Jensen posted this 02 November 2023

As of 2023-11-02  I noted there was an update:

But this has not  made any potitive changes on my system!!! Still no settings in the utility can be seen/set

GreyT

Palle Jensen posted this 08 November 2023

Just as a round off, the status is this:

On a hunch I started my Mac sonoma system in protected mode, and it turned out that the Uitilty worked fine now (as it did in normal mode in Ventura and before).

The data on the pegasus's is working fine and undisturbed :-)

So I gather there is a tiny bug somewhere in the present version of the utility... and look forward to a fix from Promise

GreyT

  • Liked by
  • Dean Biffin
Thomas Agatz posted this 14 November 2023

@Palle Jensen

I'm still on MacOS Monterey on my M1 Macbook Pro, because I'm afraid the Promise tool for my Pegasus2 R6 won't work. Or.. I believe it would wount, but if a disk crashes, I need to be able to get it up running again with the utility.

How does startup in protected mode work? Never heard of that.

Palle Jensen posted this 07 December 2023

Trying out once more I get this warning from LittleSnitch fiilter. Seems not to be able to conenct to this initial (faulty) link!!!

any comments to this?

Julien Lem posted this 08 December 2023

Bonjour Palle Jensen,

Vous utilisez LittleSnitch car avec Sonoma en mode non protégé pour faire monter Pegasus ?

 

R P posted this 08 December 2023

Hi Palle,

I've been working with the development team on this and have some new information.

The network access is only to determine if the firmware on the attached Pegasus units is up to date.

What is known is that if the Pegasus Utility can't contact the server, it's not a problem. What is not known is what happens if the Utility is blocked by the macOS firewall.

For a test, could you try disabling the firewall and see if the Utility starts? If it does you can enable the firewall and let the Promise Utility through the firewall. Both options are explained in this Apple KB.

  • Liked by
  • Palle Jensen
Palle Jensen posted this 10 December 2023

Thank you RP

I do not use the Apple  firewall, but I use a UNIFI system on top of my network. I have never had any interruption from that setup

s mentioned earlier,  a mac running Ventura, on the same network setup will show the Promise Utility working perfect!

GreyT

 

Michael Wiser posted this 22 December 2023

Has the Pegasus2 R4 (or other similar models) been tested againt the new macOS 14 Sonoma that was released today? I do not want to upgrade my M1 Mac Mini host before knowing it will continue to function with the R4.

 

 

I just updated and whenever i plug my R2 in it crashes my machine. is there any firmware updates for the R2?

R P posted this 02 January 2024

Hi Michael,

I have both a Pegasus1 and Pegasus2 attached to my M1 mac mini. They work fine with Sonoma, Ventura and Monterey.

You may have the wrong driver installed. This is a link to the M1 driver for your mac.

  • Liked by
  • Gene Carbonell
Gene Carbonell posted this 29 January 2024

Hi Michael. I have an M2 Macbook and this worked great. I can't seem to find this version in the downloads section for the Mac, so thanks again. This was a life saver.

 

Hi Michael,

I have both a Pegasus1 and Pegasus2 attached to my M1 mac mini. They work fine with Sonoma, Ventura and Monterey.

You may have the wrong driver installed. This is a link to the M1 driver for your mac.

Palle Jensen posted this 08 March 2024

Just an update on the ("old") Promise Utility. It has worked fine for some time, possibly liking one of the recent Sonoma updates.

As of today 2024-03-08 My Macs are running Sonoma 14.4, and the Utility is Version 4.06.0000.04 (C04)

and everyngting is working as expected

GreyT

Close