Pegasus1 R6 Won't mount to Mac Studio M1

  • 230 Views
  • Last Post 04 October 2023
Terrance Wong posted this 02 October 2023

My Mac Studio is running Ventura 13.6 and I've followed your KB guide for M1 chips:

For a Pegasus 1 with a modern macOS.

Use the latest Pegasus 1 firmware v5.04.000061

There is a KB on updating firmware on the Pegasus 1 and Pegasus 2

Use the latest Pegasus32 driver. For Intel macOS, the driver is builtin. For M1 macOS use the DEXT driver v21.1.0-2

Do not use the latest Promise Utility, use a slightly older version v4.06.0000.01

I've updated to the recommended firmware using the CLI Terminal method, and installed the recommended DEXT driver.  I've rebooted the Mac and the Pegasus and the raid will still not mount.  I'm using Apple's TB2 to TB3 adapter.  When I look into my Thunderbolt connections it does not detect the Pegasus.  When I connect the Pegasus to my Mac Pro 2013, it works fine.  Any suggestions?

Order By: Standard | Latest | Votes
R P posted this 02 October 2023

Hi Terrance,

After the DEXT is installed, it's necessary to 'accept' the driver in System Settings > Pricacy & Security before it will run.

You can find the state of the driver with this terminal command (do not use the Promise Utility).

systemextensionsctl list | grep pegasus

----
EDIT: Missed this...

When I look into my Thunderbolt connections it does not detect the Pegasus. When I connect the Pegasus to my Mac Pro 2013, it works fine.

This is the problem. If the Pegasus does not show in the System Report Thunderbolt section, then the Mac can't see it and the driver also cannot see it.

You need to figure out why. It's either the TB2 cable or the Adapter.

 

Terrance Wong posted this 03 October 2023

Hello, I've confirm that the driver is enabled:

268CCUR4WN com.promise.driverkit.pegasus (21.1.0/1) com.promise.driverkit.pegasus [activated enabled]

 

I've tried another cable and still nothing.  The adapter was able to connect my other TB3 Raid to the Pegasus as I was able to transfer files over to the TB3 Raid.  Wouldn't that confirm that its not the adapter?

Terrance Wong posted this 03 October 2023

Wow, I rebooted the Pegasus and it now mounted! Still doesn't show up on the Thunderbolt system info though.

R P posted this 03 October 2023

Hi Terrance,

Wow, I rebooted the Pegasus and it now mounted! Still doesn't show up on the Thunderbolt system info though.

That's odd. But at least the volume is mounted.

Does the Promise Utility see the Pegasus?

 

Terrance Wong posted this 04 October 2023

Yes the utility sees the pegasus.

Close