Pegasus1 R4 compatibility with Mac OS 10.11.6 or later

  • 90 Views
  • Last Post 12 September 2018
Ralf Hartings posted this 11 September 2018

Hi.

I read in the Pegasus R4 compatibility list , downloaded from the Promise website, that Mac OS 10.11.3 is officially supported and this version is the latest in the list :-(.

Today I run 10.10.5 as I am afraid my R4 will not work any more if I upgrade the Mac. My firmware on the R4 is the latest (...61 version). I could upgrade safely to 10.11.3, but I cannot find the 10.11.3 version of Mac OS, so I am stuck.I only find the latest one 10.11.6.

Is the latest version 10.11.6 also supported? What about the new High Sierra?

I have searched and searched, but not able to find anything..

Any help is appreciated! Thanks!

Order By: Standard | Latest | Votes
Pradeep Chidambaranath posted this 12 September 2018

Hi Ralf,

The Pegasus R4 units has reached its end of life so there will not be any software or hardware update for this unit. However, the unit will work with the latest version of MAC OSX 10.13.6. Kindly make sure to install the Pegasus drivers for MAC before connecting the unit and it will work.

Regards
Pradeep C

Ralf Hartings posted this 12 September 2018

Pradeep, many thans for the reply!

As my R4 is presently running on my iMac, it should mean that the correct drivers are already installed, right?

When I run the "Check for update...." in the Promise Utility, the system says "Promise Utility/firmware is currently the newest version available". Doesn't say anything about the driver though...

Am I fine or should I (re-)install the drivers? I cannot find which version I have installed on my iMac.

The latest is apparently:

Pegasus Series Driver for Mac

Pegasus series Driver for Mac

  MAC OS X 10.10 or above

  2017-05-10    SR3.0.2

Thanks for your input again!

regards,

Ralf

Close