Pegasus Series utility

  • 175 Views
  • Last Post 04 April 2023
Hervé Marandon posted this 28 March 2023

Hello,

 

Does anyone already installed 3 last versions of Pegasus Series Utility for Mac (4.04.000048, 4.04.000047, 4.04.000046) on MacOS 10.13.6 High Sierra (my Mac can't be upgraded much more)?

These 3 versions are mentioned 10.13 / 10.15 compliant.

I've installed and launched these softwares one after one and all are affected by same behaviour.

All function icons are missing in top of utility window (see 3 screenshots).

I've installed 4.04.000046 version on MacOS 10.15.7 Catalina (another Mac lent to me) and function icons are present (see 4th screenshot).

As you can see on last 5th screenshot 4.04.000042 on MacOS 10.13.6 High Sierra, utility is OK.

Can developpers verify it, please ?

Thank you very much.

 

 

 

 

Order By: Standard | Latest | Votes
R P posted this 28 March 2023

Hi Hervé,

All function icons are missing in top of utility window (see 3 screenshots).

This might still be functional, have you tried clicking on the words (ex, Physical Drive)?

As you can see on last 5th screenshot 4.04.000042 on MacOS 10.13.6 High Sierra, utility is OK.

This would seem a viable option.

Also, have you tried 4.06.0000.01? I just installed it on a customer's old iMAC running Mohave and it was working OK. That's one macOS later than High Sierra, but it might work on High Sierra.

 

 

Hervé Marandon posted this 29 March 2023

Hello R P,

Thank you very much for replying, very nice of you.

First, yes of course (before posting) i've tried to click on all "words" and all clicks didn't brought anything (in fact there is no action on screen, just like a blank window with no action-text or no action-icon).

Second, according to your advice, i've installed 4.06.0000.01, but it could'nt be launched (see screenshot).

 

Nothing appened after clicking "Cancel" either "OK" checkboxes.

Utility didn't launched and killed itself without any messages.

I didn't tried installed this version before you adviced me because it's mentioned " Support for macOS 11.0 or above on Apple-M1 Mac and Intel CPU Mac ".

As you can see, in my case it can't be launched with MacOS 10.13.6 High Sierra.

Looking forward to hear from you.

Have a nice day R P.

 

R P posted this 29 March 2023

Hi Hervé,

I think we've been going about this the wrong way. What is needed is the Promise Utility that was out when High Sierra was the current macOS. High Sierra was introduced in 2017, so the Promise Utility released in that timeframe should work.

Please uninstall any installed Promise Utility and try installing v4.02.0000.21

Hervé Marandon posted this 04 April 2023

Hello R P,

As you can verify upper and according to as i've wrote, last version functionnal for High Sierra 10.13.6 is 4.04.000042 (personaly tested). - As you can see on last 5th screenshot 4.04.000042 on MacOS 10.13.6 High Sierra, utility is OK -.

But as there were three new versions (4.04.000046, 4.04.000047, 4.04.000048) available mentioned High Sierra 10.13 compliant (you'll easily understand), i wanted to test them, (i saw that quickly after created this post, 47 and 48 were removed).

Of course, as you've wrote, 4.02.0000.21 works with High Sierra.

Last point : Don't you think it will be appropriate to remove "Support for MacOS 10.13" on links 4.04.000046, 4.04.000047, 4.04.000048 for Pegasus 3 and Pegasus 32 (to let only "Support for MacOS 10.14, 10.15") ?

Thank you very much and have a nice day R P.

Close